Since today, without having changed ANYTHING to the configuration, Adobe Reader does not work correctly with TexNicCenter anymore. Any time I try to preview a document, TexNicCenter crashes. I suspect that this damned Adobe software has (unsolicitedly) updated itself. Can anyone help me out here? It's driving me nuts...

EDIT Problem has been solved thanks to Sebastiano. I had to follow the following configuration: How to configure TeXnicCenter 2.0 with Sumatra (2013--2016 version)

Basically, Adobe is crap.

  • 2
    Use a decent non-blocking PDF viewer and you should be fine.
    – Skillmon
    Oct 3, 2018 at 17:13
  • You can use SUMATRA pdf.
    – Sebastiano
    Oct 3, 2018 at 17:17
  • I have been trying to install Sumatra, literally copying off all the settings described in the manual, but still I get the dreaded [ForwardSearch("%bm.pdf","%Wc",%l,0)] Cannot Execute the Command-message
    – Werner
    Oct 3, 2018 at 17:19
  • 1
    @Werner Look here: tex.stackexchange.com/questions/116981/…
    – Sebastiano
    Oct 3, 2018 at 17:31
  • 2
    Regarding adobe: you only have to change the server name for AcroViewR18 to AcroViewR19, see tex.stackexchange.com/questions/453527/… Oct 3, 2018 at 21:44

1 Answer 1


The EZ guide to SumatraPDF with TeXnicCenter

SumatraPDF can be called by DDE (Traditionally) or Command Line (Now Preferred)

Press Alt+F7 (Build > Define Output Profiles)

For any one of the PDF Profiles e.g. LaTeX > PDF

for Executable path it should have something like

C:\Program Files (x86)\SumatraPDF\SumatraPDF.exe -inverse-search "\"C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe\" /ddecmd \"[goto('%f','%l')]\""

Don't worry if it doesn't, were going to remove all that crêpe later. If there is nothing then select the … and navigate to the correct c:\Program Files …\SumatraPDF\SumatraPDF.exe then select it then click the open button

IMPORTANT if -inverse-search etc. is not there DO NOT ADD any of the old suggestions

Go back to the editor and using any simple .TeX press Ctrl+Shift+F5 (Build and view)

SumatraPDF should have fired up with the compiled PDF

Go To Settings > Advanced Options

and going down the entries check or change the following

ReuseInstance = true
ReloadModifiedDocuments = true

InverseSearchCmdLine = "C:\Program Files\TeXnicCenter\TeXnicCenter.exe" /nosplash /ddecmd "[goto('%f', '%l')]"
InverseSearchCmdLine = "C:\Program Files (x86)\TeXnicCenter\TeXnicCenter.exe" /nosplash /ddecmd "[goto('%f', '%l')]"

EnableTeXEnhancements = true
UseTabs = true


now a double click in the PDF should take you back to TeXnicCenter either in an included file or the main file. IF not, check the syntax of the InverseSearchCmdLine = matches YOUR location for TeXnicCenter

Back in the editor press Alt+F7 (Build > Define Output Profiles) and for each of the PDF options select viewer

In the Executable path section REMOVE any thing after the .exe

In the View project's Output select Command line argument and check it is "%bm.pdf"

In Forward search change it to -forward-search "%Wc" %l "%bm.pdf"

Check all 5 PDF profile options are the same (Copy and paste) now hit OK enter image description here

Whistles and Bells (Extra bonus features with recent SumatraPDF)

In SumatraPDF Settings > Advanced options there are other settings for color of forward search highlight etc.

If you have a whatever.pdf, whatever.synctex(.gz) and whatever.tex file in the same folder then you can start by opening the PDF and a double click anywhere will open the tex editor with the cursor at the right file position even if the editor was not started first.

If you have multiple (or portable) editors you can set up BATch ComManDs to change the editor name/path via an external -inverse-search call to SumatraPDF however it only needs to be done once per session not at every internal call from the editor.

If you are having problems with the wrong files opening or errors about files not found on path e.g. running on Linux under Wine or unusual project file structure then you will need to adjust the placeholders see the full updated totorial

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.