1

Using the style dinat for the package natbib, the references in the bibliography do not have a period . at the end.

How do I add it?

1

1 Answer 1

2

I suggest you proceed as follows:

  • Find the file dinat.bst in your TeX distribution. Make a copy of this file and call the copy, say dinat-mod.bst.

  • Open the file dinat-mod.bst in a text editor. The editor you employ for your tex files will do fine.

  • In the file, locate the function out.bibitem.end. In my copy of the file, this function starts at line 522.

  • Add the instruction add.period$ at the start of the function. It should then look like this:

    FUNCTION {out.bibitem.end}
    % end of entry
    { add.period$
      write$
      newline$
    }
    
  • Save the file dinat-mod.bst either in a directory that's searched by BibTeX or in the directory where your main tex file is located. If you choose the former option, be sure to update the filename database of your TeX distribution suitably.

  • In your main tex file, change the instruction \bibliographystyle{dinat} to \bibliographystye{dinat-mod}. Then, run a full recompile cycle -- LaTeX, BibTeX, and LaTeX twice more -- to fully propagate all changes.


A full MWE (minimum working example):

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@misc{aa,author="Anne Author",title="Thoughts",year=3001}
\end{filecontents}

\documentclass{article}
\usepackage[ngerman]{babel}
\usepackage{natbib}
\bibliographystyle{dinat-mod}

\begin{document}
\cite{aa}
\bibliography{mybib}
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .