1

I've got some long footnotes that are exceeding the text bounding box and overflowing into the footer. This becomes a problem when they overlap with the page numbers.

Here's an MWE of what I'm getting:

\documentclass[nofootinbib]{revtex4-1}

\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage{fullpage}
\usepackage[pass, showframe]{geometry}

\parskip = 1mm

\begin{document}

\blindtext

\blindtext

\blindtext

\blindtext

\blindtext

\blindtext

Here we are about to have a footnote\footnote{\blindtext[2]}. \blindtext\blindtext

\end{document}

Note that I've turned on showframe in the geometry package to see what's going on. Here's the result:

Screenshot of MWE

Note that the footnote is completely overflowing into the footer and beyond.

I'm not sure what's causing this behavior. Any suggestions welcome.

5
  • 1
    Works fine with article class, so something to do with revtex4-1. – Peter Grill Oct 3 '18 at 19:08
  • Indeed. Unfortunately, I need revtex4-1 for other purposes and can't switch to article. – Jolyon Oct 3 '18 at 19:16
  • Since revtex is made with a very specific purpose, perhaps this is intentional, trying to keep people from writing excessively long footnotes. – daleif Oct 3 '18 at 19:23
  • @Jolyon: Yep. Wasn't trying to suggest you switch. My comment was just to narrow down the problem to the class. – Peter Grill Oct 3 '18 at 19:34
  • Some more playing: If you add twocolumn to the document class options, it behaves properly. So it's an issue with footnotes in onecolumn mode in revtex4-1... sigh. – Jolyon Oct 3 '18 at 19:50
0

A colleague passed along this solution: add \count\footins = 1000 immediately after \begin{document}. I don't know what it does or how it does it, but apparently it works the required magic. Explanations welcome.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.