1

I'm using the biblatex-apa package with Biber as the backend programme. With the package comes - as far as I understood - following: when mentioning a citation for the first time, all Authors should be named, in subsequent citations there should appear only the first authors name + et al.

The truncation does not work in my document, it shows all 4 authors all the time, no matter how often I use them.

Since I couldn't find any help on the internet, I decided to post it here. Does someone see a mistake?

\begin{filecontents*}{apa.bib}
@article{Zitat, author = "Name Nachname and Name1 Nachname1 and Name2 Nachname2 and Name3 Nachname3", 
title = "Titel des Artikels", 
journaltitle = "Zeitschrift", 
volume = "10", 
number = "4", 
pages = "518--532", 
date = "2015", }
\end{filecontents*}

\documentclass[man]{apa6}
\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc} \usepackage[ngerman]{babel}
\usepackage{tabularx}
\usepackage[style=apa,sortcites=true,sorting=nyt,backend=biber, style=authoryear, maxbibnames=7, maxcitenames=7]{biblatex}
 \usepackage{csquotes}
\DeclareLanguageMapping{ngerman}{ngerman-apa} \providecommand{\apashortdash}{-}
\addbibresource{apa.bib}
\shorttitle{}
begin{document}
\parencite{Zitat}\\
\textcite{Zitat}
\end{document}
  • Welcome to TeX.se, and thanks for posting a minimal example document with your question! – Alan Munn Oct 7 '18 at 19:31
2

You override the apa style by adding style=authoryear. Remove that (and the other options such as maxnames which defaults to 7 for the apa style), and you should be fine.

\begin{filecontents*}{\jobname.bib}
@article{Zitat, author = "Name Nachname and Name1 Nachname1 and Name2 Nachname2 and Name3 Nachname3", 
title = "Titel des Artikels", 
journaltitle = "Zeitschrift", 
volume = "10", 
number = "4", 
pages = "518--532", 
date = "2015", }
\end{filecontents*}

\documentclass[man]{apa6}
\usepackage[utf8]{inputenc} 
\usepackage[T1]{fontenc} \usepackage[ngerman]{babel}
\usepackage{tabularx}
\usepackage[style=apa,backend=biber, ]{biblatex}
 \usepackage{csquotes}
\DeclareLanguageMapping{ngerman}{ngerman-apa} \providecommand{\apashortdash}{-}
\addbibresource{\jobname.bib}
\shorttitle{}
\begin{document}
\parencite{Zitat}\\
\textcite{Zitat}
\end{document}

output of code

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.