I have freshly installed the newest version of Texmaker on Ubuntu 18.04 and it works but not as intended. When I run the app everything looks kinda zoomed in, the whole GUI looks weird.

Does anyone maybe know how to solve this problem?


texmaker after run


The latest versions of TeXmaker have a start-up setting for scale, it may be yours got installed at a screen default other than 1.0. The command line default value could be ended -dpiscale 1.0 you may wish to try -dpiscale 0.75 or 0.8 and see if that's better.

From the TeXmaker manual "the environment variable QT_SCALE_FACTOR will be set to x before building the GUI (same behavior than adding "export QT_SCALE_FACTOR=x" to the environment variables)"

It is possible some other QT application has set that value for its own use and TeXmaker is respecting that value. Look in your system and user environment settings to see if its there.

Note for Windows users with a hi-res monitor you might want to add -dpiscale=1.5 to the start up shortcut or for a start-up.CMD add SET QT_SCALE_FACTOR=1.5

  • And how can I edit those values? What are the terminal commands for that or it is possible to do it via some other app. – Desibre93 Oct 9 '18 at 13:35
  • Sorry I don't know Ubuntu methods when you call texmaker you would add texmaker -dpiscale=0.8 if that helps you chose a value then for a permanent setting how would you normally add system variables I understand that you need to add environment variables to sudoers file via sudo visudo then use Defaults env_keep += "$QT_SCALE_FACTOR=0.8" however this is all guess work based on this discussion and answer stackoverflow.com/questions/8633461/… so best to raise this question on an Ubuntu forum – user170109 Oct 9 '18 at 14:48
  • If you do find an answer that equals/betters mine you can write your own answer and accept that. – user170109 Oct 9 '18 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.