2

I recently begun getting the following error during my thesis writing:

! LaTeX Error: Command \texteuro unavailable in encoding OT1.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              

?

Also, the error is not immediately displayed as it normally would be. Instead, I had to manually click the log to find the error.

The line points me towards my bibliography reference \bibliography{mybib} which has been working perfectly throughout the project. It started occurring once I tossed in a large table containing a rather large amount of references (probably around 100 or so). However, I've tried clipping out the table, clipping out all text in my bib file (both new and old) and I am unable to compile using my build: PDFLaTeX, PDFLaTeX, BibTeX, PDFLaTeX. I can compile using PDFLaTeX alone. I am also able to compile the whole build if I comment out the \bibliography{mybib} line. I use Texmaker as my editor / compiler.

The odd thing is, that I don't have any appearances of \texteuro or in any of my files.

With my deadline being in a week, I really hope someone is able to help! Thanks!

EDIT: I was finally able to run my compiling build. I'm unsure as to why I was receiving the error message described above, however.

SOLUTION: The code \renewcommand\texteuro{FIXME} allowed for the unproblematic references to get included in the document. From here, I investigated the logs to identify which references were not defined - and fixed these in my bibliography file. This solved my issue.

Thanks a bunch to those of you who took your time to assist!

  • 3
    Welcome to TeX.SX! You probably have \texteuro or in your .bib file, since the compiler is complaining about \bibliography{mybib}. – Phelype Oleinik Oct 9 '18 at 14:52
  • Hi Phelype, thanks for the quick reply. Unfortunately that is not the case. I've searched through every individual section and no occurrences of either of those are there. – Niklas Broge Oct 9 '18 at 14:54
  • 2
    Could you please reduce your document to a minimal working example with bibliography (MWEB) so we can try to find out where is that symbol coming from? Or, you could try to load textcomp to see if will provide the missing symbol... – Phelype Oleinik Oct 9 '18 at 14:57
  • 3
    in your preamble add \renewcommand\texteuro{FIXME} then the error will go and look in the generated pdf for FIXME – David Carlisle Oct 9 '18 at 15:06
  • 1
    @NiklasBroge If you can reproduce the error without the bibliography, even better. Reduce the code as much as you can. Without seeing your document we can only guess what's going on. – Phelype Oleinik Oct 9 '18 at 15:29
1

In your preamble (or possibly better just after \begin{document} add

 \renewcommand\texteuro{FIXME} 

then the error will go and look in the generated pdf (possibly in the bibliography) for FIXME, and adjust teh text not to have a euro, then remove the debugging definition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.