1

At work I have a centOS computer, which runs an outdated version of texlive. A texlive developer recomends installing the upstream version in this CentOS forum. I installed the 2018 version of texlive. It has several path locations:

    <D> set directories:
   TEXDIR (the main TeX directory):
     !! default location: /usr/local/texlive/2018
     !! is not writable or not allowed, please select a different one!
   TEXMFLOCAL (directory for site-wide local files):
     /usr/local/texlive/texmf-local
   TEXMFSYSVAR (directory for variable and automatically generated data):
     /usr/local/texlive/2018/texmf-var
   TEXMFSYSCONFIG (directory for local config):
     /usr/local/texlive/2018/texmf-config
   TEXMFVAR (personal directory for variable and automatically generated data):
     ~/.texlive2018/texmf-var
   TEXMFCONFIG (personal directory for local config):
     ~/.texlive2018/texmf-config
   TEXMFHOME (directory for user-specific files):
     ~/texmf

Now I would like Lyx to point to the new texlive version.

This question explains how to change the Tools / Preferences / Paths on windows. It did change Tools / Preferences / Paths / path prefix to "/usr/local/texlive/2018/", but Lyx seems to be still using the old path configuration. See screenshot:enter image description here

I guess there is another way to tell Lyx which version of TexLive to use?

  • Maybe in the settings window (especially the LaTeX Preamble), or using Evil Red Text? – Karlo Oct 9 '18 at 15:56
  • I have now switched to an Ubuntu computer which doesn't have the issue. – Paul Rougieux Oct 10 '18 at 10:10
3

If TeX Live is well installed, simply use the Rescan button that you show in the image, then go to Tools > Reconfigure.

After some time a message will warn you about restart LyX. Do that and now it should work with the 2018 version.

BTW, yo do not need add /usr/local/texlive/2018/ to any path in Preferences, but first, in a terminal, be sure that echo $PATH show /usr/local/texlive/2018/bin/x86_64-linux.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.