2

I am working on a latex file and also need to meet the following format requirement:

Font : Times New Roman

Font Size : 12 point

Margin : 2.5 cm all round

Spacing : Single-line spacing

PDF version: compatible with Adobe Acrobat Reader 5

So this is currently what I am using:

\documentclass[12pt,a4paper]{article}  <--- font size

\pdfminorversion=4     <---- pdf version
\pagenumbering{gobble}

 \usepackage[a4paper,top=2.5cm, bottom=2.5cm, left=2.5cm, right=2.5cm]{geometry}   <---- margin

\usepackage{mathptmx}  <---- font time
\usepackage{lipsum}

\begin{document}

 \lipsum

 \end{document}

However, the really annoy thing is that I simply cannot meet the margin requirement, after printing out on the paper and use a ruler to test.

I configure the printer with "A4" size:

enter image description here

But when I use the ruler to check the margin, this is what I find:

left margin: 2.5cm

right margin: about 2.9 cm

top margin: 3 cm

bottom: 4.5 cm

I have been tweaking the setting for quite a while, but still have no idea to fix the issue.

So here is my question:

  1. how should I fix the margin issue, and meet the requirement of "all round 2.5cm"?

  2. Could anyone provide some foolproof working example, to meet all the formatting requirements? I am rushing for this draft and probably have no time to hack more. It would be great if anyone can provide a working example.

  • 1
    Post a minimal working example ending with \end{document} and showing the problem. Use the package lipsum to produce enough text and see the margins. Remove the irrelevant packages. Use the showframe option in geometry, and try also the layout package to see what are the real lengths. And check also the options of your printer: if you select "scale to fit" you have every chance of change the margins. – Fran Oct 9 '18 at 20:00
  • your printer settings are not correct. try to remove "scale to fit" – Zarko Oct 9 '18 at 20:04
  • @Fran, I have updated my question with a mwe. Thanks. – lllllllllllll Oct 9 '18 at 20:25
  • Hello @lllllllllllll! For the 2.5cm all around margin it is enough to type margin=25mm. Maybe this helps you. – Su-47 Oct 9 '18 at 20:43
3

Using the MWE below you can see that the margins in the PDF are those specified in the geometry package (that in this case you can simplify as commented above). So for example, you can see that in the diagram layout (click on the image to zoom it) that \textwidth is 455pt (= 16 cm), that is the expected when the margins are 2.5 cm in a A4 paper.

\documentclass[12pt,a4paper]{article} 
\usepackage[margin=2.5cm]{geometry}  % add also "showframe" options  
\usepackage{lipsum}
\usepackage{layout}
\begin{document}
\layout
\lipsum[1-20]
\end{document}

mwe

When printed the margins could be different because the position of the paper input tray or wrong printer options. In particular as you set "scale to fit" seem that you PDF has been zoomed to fit all the PDF (including margins) to the effective printing area of your printer (that hardly could be as big as the page area).

  • The key here is to remember the distinction between what is sent to the printer and what the printer sends to the page. The former is controlled within LaTeX and geometry. The latter is controlled by the printer scale and margins settings. As noted, CLICK FILL TO PAGE. When this does not work, readjust geometry to account for the printer margin offsets. This could be done for example by using the binding offset as a negative value. – Jeffrey J Weimer Nov 8 '18 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.