In relation to this question, I just discovered, that the official Adobe Reader doesn't display TextFields, which have the flag borderstyle=U set.

Minimal example:

\documentclass{article}
\usepackage[hidelinks]{hyperref}

\begin{document}

\begin{Form}
  \TextField[width=0.98\linewidth,bordercolor={0 0 0},charsize=0pt,borderstyle=U]{}\\
\end{Form}

\end{document}

Display as expected in evince, not at all in Adobe Reader (Windows 10).

Any ideas?

PS: Exact version is Adobe Acrobat Reader DC Version 2018.009.20044. PPS: Also tested in Adobe Acrobat Pro DC Version 2015.006.30033

up vote 6 down vote accepted

The problem is not caused by the borderstyle, it is the empty field name. A text field without name is dropped by Adobe Reader, so you either have to use

\documentclass{article}
\usepackage[hidelinks]{hyperref}

\begin{document}

\begin{Form}
  \TextField[width=0.98\linewidth,bordercolor={0 0 0},charsize=0pt,borderstyle=U]{Some name}\\% <-- Insert a nice name here, it will be printed next to the field
\end{Form}
\end{document}

or, if you do not want the fieldname to be shown next to the field, use the name= option:

\documentclass{article}
\usepackage[hidelinks]{hyperref}

\begin{document}

\begin{Form}
  \TextField[name=SOME_UNIQUE_NAME,width=0.98\linewidth,bordercolor={0 0 0},charsize=0pt,borderstyle=U]{}\\
\end{Form}

\end{document}
  • Thanks. The solution with setting a name is really convenient. It works except in ”Preview“ on MacOS 10.9.5. I haven't had a chance to test more recent MacOS versions yet. – MPW Oct 11 at 12:07

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.