1

If I type:

\author{Alpha\thanks{} and Beta\thanks{}}

then it is typeset as "Alpha*and Beta*" instead of "Alpha* and Beta*" as I would expect (i.e. there is no space after the first footnote mark). This does not happen outside \author. The obvious alternative to try:

\author{Alpha\thanks{}\ and Beta\thanks{}}

does not help. I can make the desired "Alpha* and Beta*" by resorting to:

\author{Alpha\thanks{}\ \ and Beta\thanks{}}

but this seems somewhat silly (and makes me worry that on another tex installation it might actually insert two spaces) Since \thanks is clearly intended to be used like this inside \author, I feel like I must be missing something about the intended invocation. How am I supposed to use \thanks so that the spacing is correct?

1

I'm assuming you are talking about one of the standard classes.

classes.dtx contains:

\def\@makefnmark{\rlap{\@textsuperscript{\normalfont\@thefnmark}}}%

compare now to the default, from latex.ltx:

\def\@makefnmark{\hbox{\@textsuperscript{\normalfont\@thefnmark}}}%

The class code changes the \hbox to \rlap, which makes the footnote mark have zero width. That's why the space disappears and that's why two spaces look correct.

I don't know the reason for hiding the width of the footnote mark. Perhaps to make the author name (in case of a single author) look "more centered"... Just guessing.

This doesn't happen if you use the titlepage option.

To avoid this you can, for instance, override the definition:

\documentclass{article}

\usepackage{etoolbox}
\makeatletter
\pretocmd\@maketitle
  {\def\@makefnmark{\hbox{\@textsuperscript{\normalfont\@thefnmark}}}}
  {}{\FAIL}
\makeatother

\title{Hello}
\author{Alpha\thanks{} and Beta\thanks{}}

\begin{document}
\maketitle
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.