149

I am writing a thesis report using LaTeX and I need to add indentations because every new paragraph starts from the initial position on the left.

How do I add indentations?

5
  • 3
    LaTeX indents paragraphs by default, except after section titles. How did you configure your document? Feb 23, 2012 at 10:03
  • 2
    I don't really understand what you're trying to do. Please add an example.
    – Thorsten
    Feb 23, 2012 at 10:03
  • 9
    Please add a minimum working example (MWE) that illustrates the problem you're experiencing.
    – Mico
    Feb 23, 2012 at 11:24
  • 3
    How are you ending your paragraphs?
    – egreg
    Feb 23, 2012 at 11:35
  • For readers: you might be looking for indentation - Indenting a whole paragraph - TeX - LaTeX Stack Exchange instead.
    – user202729
    May 19, 2022 at 13:46

6 Answers 6

97

Paragraph indention is controled by the parameter \parindent. In most document classes it is set to a positive value so you should see indentations. If this is not the case you can set this parameter in the document preamble to whatever value you wish, e.g.

\setlength\parindent{24pt}

Of course, a requirement is that you mark up your paragraphs: a paragraph ends by either a blank line or by the command \par. If you instead just used \\you have directed LaTeX to start a new line but not a new paragraph.

2
  • 3
    Just one comment (also for @pavani). It is usually a good idea to define \parindent in terms of the type size. That way the indentation will scale if you change the size of the type. Bringhurst recommends indenting the paragraph by the same size as the type or the leading. So if you set the size using \fontsize{11pt}{13pt}\selectfont, you should use 11 or 13 pt.
    – user10274
    Feb 21, 2013 at 19:34
  • 1 em is another common length to use. Although I have noticed that a lot of american english texts seem to have a bigger indentation. It all varies... :)
    – jonalv
    Mar 3, 2014 at 14:46
83

I think you need:

\indent Here comes your text
6
  • 50
    if paragraphs are not indented by default, that means that the paragraph intention is turned to zero in the class file used. In that case \indent will add zero indentation too Feb 23, 2012 at 11:11
  • 1
    Hmmm, isn't it also a possibility that the template that the OP uses does not add a \indent at the start of a paragraph? Or is setting the indent length to zero the only way of doing this? Feb 23, 2012 at 11:18
  • 3
    TeX adds an indentation box automatically on every paragraph (unless explictly directed not to), so there is no need to say \indent except in very special circumstances. There is the possibility that some environment explicitly does something like \noindent but from the little information above my guess it is a more general problem of not having any indentation. Feb 23, 2012 at 11:29
  • 1
    @PaulHiemstra: We don't know until the OP adds an MWE. Till then you are waisting your crystal ball. Feb 23, 2012 at 13:01
  • 7
    @Dimitri that is strange as \indent has no effect at the start of a paragraph. Are you sure that this answer worked for you? Mar 3, 2014 at 15:47
46

To forcibly insert a space that is the same length as an indentation you can use the following:

\hspace{\parindent}

This can be useful if you start a new section with a framed theorem, etc., and latex does not recognize it as a paragraph.

2
  • 2
    Thought about the same, but for some reason, the indentation by \hspace{\parindent} is larger than an automatic indentation. Do you know why and how to fix it?
    – M. Winter
    Jan 29, 2019 at 12:23
  • 1
    @M.Winter I got it to work by not putting a space between the command and the text. May 3, 2019 at 16:06
15

I assume you want to add indentation after the section or subsection title as LaTeX does indentation of the other paragraphs first. The solution I used was to use a package, \usepackage{indentfirst}. You can download indentfirst.sty from the web. But there are reasons concerning proper style of why the first paragraph should not be indented.

2
  • 1
    1.) A tip: You can use backticks ` to mark your inline code as I did in my edit. 2.) The package indentfirst is already part of all important TeX distributions or at least can be installed with the package managers, so there’s no need for downloading.
    – Speravir
    Feb 21, 2013 at 21:22
  • The proper style (whether first paragraph should be indented or not) depend on the national rules (for example Polish typografy requires it). Sep 11, 2018 at 18:43
14

\vspace*{6mm} will work by default.

Similarly, \hspace*{10mm} will add a line spacing, but you have to reuse it every time you need the space.

4
  • 4
    Welcome! This is not a good answer. The first suggestion is for vertical space. The second is for horizontal space, but not indentation. Moreover, neither is usually a good way to add space in a document, even when you do need to do it manually as neither includes any glue.
    – cfr
    Sep 23, 2017 at 2:39
  • 4
    @cfr, can you please explain what glue means here? Mar 29, 2018 at 7:51
  • 1
    It is the only solution from this thread that worked out of the box for me.
    – ema
    Jul 9, 2021 at 11:34
  • If you need to say "ignore what I am doing for paragraphs, and don't change what I am doing for paragraphs, but just indent this one line anyway" then this seems to be the correct answer. Nov 3, 2022 at 7:33
5

It sounds like you have forgotten you have \usepackage{parskip} in your preamble. Remove it.

I keep trying to post this, but keep getting an inane message saying it won't be, because it looks suspicious. Let's see if this additional note helps it slip through.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .