1

Currently looks like:

My graph and data table

Code:

\documentclass[a4paper]{article}
\usepackage{siunitx,tikz,pgfplots,pgfplotstable}

\begin{document}

\begin{minipage}{.4\textwidth}
% some text before...
Calciumcarbonat: \(m(CaCO_3)=M\cdot n=\SI{100,1}{\frac{\milli\gram} 
{\milli\mol}}\cdot n(CaCO_3)\).\\
    \begin{tikzpicture}
        \begin{axis}[xlabel=\(t\) in \(\si{\second}\)]
            \addplot[smooth,thick] table[x=time,y=allvol] {myfile.dat};
            \addlegendentry{\(V\) in \(\si{\milli\liter}\)}
            % some more graphs
        \end{axis}

        \pgfplotstabletypeset[columns={time,allvol,nco2}] {myfile.dat};
    \end{tikzpicture}
    Reaktiongsgeschwindigkeit zu Beginn %more text...
\end{minipage}

\end{document}

I have put the whole construct in a minipage because there are two graphs, and I want them to display next to each other. Works nicely, but the layout of the graphs and tables and text below is messed up.

  • Why is the table overlapping with the graph and the text below?
  • Why is the text right below the graph and leaves no space for the table?

Any ideas on how I can fix these problems?

Thank you in advance..

closed as off-topic by user121799, Phelype Oleinik, siracusa, Bobyandbob, Stefan Pinnow Oct 14 '18 at 5:33

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You can try to wrap your axis and table in two scopes and provide a xshift=...,yshift=... options to one of them – BambOo Oct 13 '18 at 16:21
  • Is there a reason that you typeset the table inside the tikzpicture? I would just put the table in a separate minipage right of the plot. Notice that it is impossible to really answer your question and test the answer since we do not have your data file. – user121799 Oct 13 '18 at 16:22
  • To typeset stuff inside a tikzpicture it really has to be put inside a \node. But in this case you can do as suggested above, and place the table outside the tikzpicture, you probably don't even need a minipage. – Torbjørn T. Oct 13 '18 at 17:15
  • @marmot that fixed it for me. Thank you a lot ^^ – writzlpfrimpft Oct 13 '18 at 20:11
  • 4
    I'm voting to close this question as off-topic because the problem was solved in the comments. – user121799 Oct 14 '18 at 0:01