0

I want to include a .svg-file, which contains a excel-table, which i exported to an pdf.file and imported it into inkscape. I am using a few quotation marks (") in the excel-table and after importing the .pdf-file into inkscape everything looks fine. In Latex i am using the package {svg} for auto generating the .pdf and .pdf-tex files. The problem is that all the qotation marks are not getting escaped (i can see that in the .pdf_tex file). How can i resolve that problem?

\documentclass[12pt,oneside,titlepage,listof=totoc,bibliography=totoc]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[babel,german=quotes]{csquotes}
\usepackage{mathptmx}
\usepackage{underscore}
\usepackage[T1]{fontenc}
\usepackage{fancyhdr}
\usepackage{fancybox}
\usepackage[a4paper, left=4cm, right=2cm, top=4cm, bottom=2cm]{geometry}
\usepackage{graphicx}
\usepackage{trimspaces}
\usepackage{svg}
\usepackage{colortbl}
\usepackage{array}
\usepackage{float}
\usepackage{footnote}
\usepackage{caption}
\usepackage{enumitem}
\usepackage{amssymb}
\usepackage{mathptmx}
\usepackage{amsmath}
\usepackage{marvosym}
\usepackage[colorlinks=true,linkcolor=black]{hyperref}
\pdfminorversion=7
\definecolor{darkblack}{rgb}{0,0,0}
\hypersetup{colorlinks=true, breaklinks=true, linkcolor=darkblack, menucolor=darkblack, urlcolor=darkblack}
\usepackage{times}
\fontfamily{ptm}\selectfont

\begin{document}

\begin{figure}[h!]
\fontsize{4}{6}\selectfont
\includesvg[width=\textwidth]{Literaturrecherche.svg}
\caption[Ergebnisse Literaturrecherche]{Ergebnisse Literaturrecherche}
\end{figure}

\end{document}

Example part of the .pdf_tex file:

\put(0.17426477,1.49716511){\color[rgb]{0,0,0}\makebox(0,0)[lt]{\lineheight{1.25}\smash{\begin{tabular}[t]{l}bitcoin) AND ("social \end{tabular}}}}%
\put(0.17426477,1.47727188){\color[rgb]{0,0,0}\makebox(0,0)[lt]{\lineheight{1.25}\smash{\begin{tabular}[t]{l}media" OR "soziale \end{tabular}}}}%
\put(0.17426477,1.45737864){\color[rgb]{0,0,0}\makebox(0,0)[lt]{\lineheight{1.25}\smash{\begin{tabular}[t]{l}Medien" OR facebook OR \end{tabular}}}}%
  • you haven't posted the relevant code to let anyone see the issue, which quotation marks need to be escaped? – David Carlisle Oct 15 '18 at 9:56
  • take a look at the example part of the .pdf-tex file, sorry for that – Dennis F. Oct 15 '18 at 9:59
  • so that should work without error, " doesn't need to be escaped in tex. If you mean that you want typographic left and right quotes it would be easiest to do that in the original source. – David Carlisle Oct 15 '18 at 10:03
  • oh you have german babel enabled, use the babel command to locally turn off the " shorthand at the point that you input the data – David Carlisle Oct 15 '18 at 10:06
  • how do i do that? – Dennis F. Oct 15 '18 at 10:08
2

Normally " would not cause an error but as you are using babel's german option it sets up " as a shorthand character to access accent and other commands.

So you can use

\shorthandoff{"}

to locally disable this while inputting the svg derived tex.

That will make it work without error but "foo" will produce ”foo” so you may in any case prefer to edit the generated tex (or change the original source) to use

``foo''

and so get left and right quotes “foo”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.