2

In beamer presentations I like to dim all of the miniframes for the first and last few slides of the talk (slides with introduction, conclusions, references, etc.; things that don't fit into any particular subsection of the talk). I used to be able to accomplish this by following each \section command with a \stepcounter{subsection} command, and also including a \stepcounter{section} command at the point in the talk where I'd like miniframes to be dimmed for all subsequent slides. This no longer works, and I am not sure why.

MWE:

\documentclass{beamer}

\usetheme[]{Madrid}
\useoutertheme[footline=empty,subsection=false]{miniframes}

\title{an awesome talk}
\author{a froody dude}
\date{\today}

\begin{document}

\begin{frame}[plain]
\titlepage
\end{frame}

\begin{frame}{slide 0}
All miniframes dimmed, as desired.
\end{frame}

\section{section 1}
\stepcounter{subsection}

\begin{frame}{slide 1}
content 1
\end{frame}

\begin{frame}{slide 2}
content 2
\end{frame}

\section{section 2}
\stepcounter{subsection}

\begin{frame}{slide 3}
content 3
\end{frame}

\begin{frame}{slide 4}
content 4
\end{frame}

\section{section 3}
\stepcounter{subsection}

\begin{frame}{slide 5}
shading on miniframes is wrong
\end{frame}

\begin{frame}{slide 6}
shading on miniframes is wrong
\end{frame}

\stepcounter{section} % This command used to result in the desired effect.

\begin{frame}{slide 5}
all miniframes should be dimmed
\end{frame}

\begin{frame}{slide 6}
all miniframes should be dimmed
\end{frame}

\end{document}

Here is what I see when I compile the above document. It's hard to tell in the above image due to the compression, but the shading on slides 7

seven

and 8

eight

is messed up.

I am running Xubuntu 18.04, TexLive 2017.

2 Answers 2

2

The good new is that with the new beamer behaviour you don't need \stepcounter{subsection} anymore.

The bad news: switching off the miniframes needs a bit of a hack:

\documentclass{beamer}

\usetheme[]{Madrid}
\useoutertheme[footline=empty,subsection=false]{miniframes}

\title{an awesome talk}
\author{a froody dude}
\date{\today}


\makeatletter
\let\beamer@writeslidentry@miniframeson=\beamer@writeslidentry%
\def\beamer@writeslidentry@miniframesoff{%
  \expandafter\beamer@ifempty\expandafter{\beamer@framestartpage}{}% does not happen normally
  {%else
    % removed \addtocontents commands
    \clearpage\beamer@notesactions%
  }
}
\newcommand*{\miniframeson}{\let\beamer@writeslidentry=\beamer@writeslidentry@miniframeson}
\newcommand*{\miniframesoff}{\let\beamer@writeslidentry=\beamer@writeslidentry@miniframesoff}
\makeatother

\begin{document}

\begin{frame}[plain]
\titlepage
\end{frame}

\begin{frame}{slide 0}
All miniframes dimmed, as desired.
\end{frame}

\section{section 1}
%\stepcounter{subsection}

\begin{frame}{slide 1}
content 1
\end{frame}

\begin{frame}{slide 2}
content 2
\end{frame}

\section{section 2}
%\stepcounter{subsection}

\begin{frame}{slide 3}
content 3
\end{frame}

\begin{frame}{slide 4}
content 4
\end{frame}

\section{section 3}
%\stepcounter{subsection}

\begin{frame}{slide 5}
shading on miniframes is wrong
\end{frame}

\begin{frame}{slide 6}
shading on miniframes is wrong
\end{frame}

\section{}
\miniframesoff

\begin{frame}{slide 5}
all miniframes should be dimmed
\end{frame}

\begin{frame}{slide 6}
all miniframes should be dimmed
\end{frame}

\end{document}
1
1

Setting the counter to 0 seems to work. Note that you don't need to step the subsection counter manually.

Partial MWE:

\section{section 3}
%\stepcounter{subsection}

\begin{frame}{slide 5}
shading on miniframes is wrong
\end{frame}

\begin{frame}{slide 6}
shading on miniframes is wrong
\end{frame}

\setcounter{section}{0}

\begin{frame}{slide 5}
all miniframes should be dimmed
\end{frame}

\begin{frame}{slide 6}
all miniframes should be dimmed
\end{frame}

\end{document}

Result:

enter image description here

1
  • This worked in in the MWE I provided, but did not work when I tried to put it into the custom beamer theme I like using for my presentations. @samcarter 's solution worked for me though!
    – teerav42
    Oct 16, 2018 at 22:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .