2

With the following code I get the warning "Incompatible color definition". When I remove the package tikz, the warning disappears. But I need this package. Can I avoid the warning? I have to use the class svmono from https://www.springer.com/engineering?SGWID=0-175-6-1381428-0

Thanks!

\RequirePackage{amsmath}            % Instead of \usepackage{amsmath} in order to avoid Warning: Unable to redefine math accent \vec
\documentclass[graybox,envcountchap,sectrefs]{svmono}

\usepackage{newtxtext,newtxmath}    % Instead of mathptmx, since with mathptmx Warning: there are no bold math fonts 
\usepackage{graphicx}
\usepackage{tikz}
\begin{document}
\begin{svgraybox}
Hello.
\end{svgraybox}
\end{document}
9
  • 1
    (1) welcome, (2) since svmono is not a standard class included with LaTeX, it might be an idea to provide a link to where you got svmono from.
    – daleif
    Oct 16, 2018 at 8:07
  • 2
    My guess is that xcolor is being loaded twice by different packages that you are using but with different colour options. Try adding \PassOptionsToPackage{svgnames}{xcolor} before your \documentclass command. I don't have svmono.cls installed so I can't test...
    – user30471
    Oct 16, 2018 at 8:08
  • @daleif Of course you're right. I provided a link (by editing the post).
    – Thales
    Oct 16, 2018 at 9:09
  • @Andrew Sounds good. But your suggestion did not help. (Messages are exactly the same).
    – Thales
    Oct 16, 2018 at 9:12
  • erh, that is not the error I get. Please find the first error in your editor, it complaines that svgraybox does not exist. So from where do you have that svgraybox should be something that is supported?
    – daleif
    Oct 16, 2018 at 9:33

1 Answer 1

2

Now I could resolve it. The solution was replacing in svmono.cls itself the command \Requirepackage{color} by \Requirepackage{xcolor}.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .