1

for my seminar paper, I have to quote a scientific paper. This is the corresponding .bib entry:

@article{hochreiter1991untersuchungen,
  title={Untersuchungen zu dynamischen neuronalen Netzen},
  author={Sepp Hochreiter},
  journal={Diploma, Technische Universit{\"a}t M{\"u}nchen},
  volume={91},
  number={1},
  year={1991}
}

In my bibliography, however, the scientific paper appears as follows

— . 1991. „Untersuchungen zu dynamischen neuronalen Netzen“. Diploma, Technische Universität München 91 (1).

The problem is that the author is replaced by a dash. Does anyone know where the error in my bibtext is?

  • 1
    Add the option dashed=false to your biblatex loading options. – moewe Oct 17 '18 at 10:09
  • My mistake, I forgot to mention that I use Sharelatex. So I only have one literatur.bib and a main.tex file. Where is the loading optins in Sharelatex? – Leon Oct 17 '18 at 10:13
  • I meant the biblatex options. You should have \usepackage[...]{biblatex} somewhere. Add dashed=false to the ... in square brackets in that line. – moewe Oct 17 '18 at 10:18
  • See also tex.stackexchange.com/q/49140/35864 – moewe Oct 17 '18 at 10:24
  • 2
    Thing is: It's not a bug, it's a feature. The dash is what the Chicago Manual of Style wants for repeated authors. – moewe Oct 17 '18 at 11:03
5

In the standard styles you could turn off the dash with the option dashed=false, see Get full name twice in Bibliography.

The styles of biblatex-chicago do not know that option and do not allow you to turn the dash off easily. It is a feature of the Chicago Manual of Style bibliography styles that they replace subsequent mentions of the same author list with a dash.

Since there is no option to turn off the dash, there is no convenient way to get rid of it, you need to play with internal macros. You can essentially tell biblatex to forget who the last author was by undefining \bbx@lasthash, which forces the style to never use the dash to replace the name.

\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[authordate,backend=biber]{biblatex-chicago}

\addbibresource{biblatex-examples.bib}

\makeatletter
\AtEveryBibitem{\global\undef\bbx@lasthash}
\makeatother

\begin{document}
\cite{knuth:ct:a,knuth:ct:b}
\printbibliography
\end{document}

bibliography of the MWE: both entries show the full author name, there is no dash

Please note that the styles of biblatex-chicago should ideally be loaded using the wrapper package biblatex-chicago and not the normal biblatex package (as shown in the MWE). But then you can't use the natbib option.

1

The following source:

\documentclass[12pt,letterpaper]{article}
\usepackage[utf8]{inputenc}
\usepackage[authordate,strict,backend=biber,bibencoding=inputenc]{biblatex-chicago}

\addbibresource{test.bib} % contains the .bib record originally posted 
\begin{document}

    \nocite{*}

\printbibliography
\end{document}

... enter image description hereproduces this result:

  • Welcome to TeX.SX. It is pretty hard to find a question to answer as a new member. Unfortunately, your answer does not answer the question or gives any useful insights. – Johannes_B Oct 17 '18 at 13:12
  • I beg to disagree. The question was "Does anyone know where the error in my bibtext is?" My answer shows the proper code using the original .bib record to provide the bibliography desired. – Bob Oct 17 '18 at 13:45
  • The error/reason that produces the dash and how to get rid of it. You do not address that. – Johannes_B Oct 17 '18 at 15:16
  • With all due respect, Johannes_B, my answer demonstrates that there is no error. The original post shows a single .bib record and my answer demonstrates that it typesets correctly. The bibliography style itself imposes the dash for additional bibliographies by the same author. The original post showed only a single record and a single output. Comments under the post reveal that others were unaware of the bibliography style features. So it appears there were problems in the original post. – Bob Oct 17 '18 at 15:56
  • The answer is technically correct (the best kind of correct) especially taking into account the wording of the question. But it does not address the underlying issue behind the question (the question-as-intended, the question-as-it-should-have-been). Unfortunately, the question does not include an MWE that properly reproduces the actual issue the OP is complaining about, namely that in a subsequent work of the same author the name is replaced by a dash. Obviously that problem only shows when there are several .bib entries. ... – moewe Oct 17 '18 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.