1

I am trying to figure out why, when using biblatex with style = apa, there is no .et al abbreviation in my text with more than 3 authors. I cannot think of any plausible explanation, maybe someone sees smth that I don't in my latex preamble.

\documentclass[12pt]{article}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}


\usepackage[
backend = biber, 
style = apa, 
defernumbers=false,
uniquelist=true]{biblatex}
\DeclareLanguageMapping{english}{american-apa}

\usepackage{xpatch}

\AtEveryCitekey{\ifciteseen{}{\clearfield{namehash}}}

\xpatchbibmacro{cite}
  {\printnames{labelname}}
  {\ifciteseen
     {\printnames{labelname}}
     {\printnames[][1-99]{labelname}}}
  {}
  {}

 \xpatchbibmacro{textcite}
  {\printnames{labelname}}
  {\ifciteseen
     {\printnames{labelname}}
     {\printnames[][1-99]{labelname}}}
  {}
  {}


\addbibresource{dummy_lit.bib} %name of the .bib file with my references

\begin{document}

I would like to have the abbreviation "et. al" in the running text whenever the references have more than three authors and not this:

\textcite{Author2000}


\end{document}

This is my bib entry stored in a separate file called: dummy_lit.bib

 @Article{Author2000,
   author       =  {Last name1, Firstname 1 and Last name2, First name2 and Last name3, First name3 and Last name4, First name4 and Last name5, First name5},
   title        =  {The title of my article},
   journal      =  {The journal},
   year         =  {2000},
   volume       =  {1},
   number       =  {2},
   pages        =  {1-10},
   keywords     =  {ref}
}
  • @moewe: Code fixed! Example can be copied and pasted without adjustments – Jo-Achna Oct 18 '18 at 14:41
4

APA style requires that up to five authors are shown in full on a first citation, lists of three to five authors are only abbreviated to "et al." on subsequent citations. See for example http://blog.apastyle.org/apastyle/2011/11/the-proper-use-of-et-al-in-apa-style.html or 6.11 and 6.12 in the Publication Manual of the American Psychological Association.

And indeed if you cite an entry with five authors twice, you get.

\documentclass[12pt]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[backend = biber, style = apa]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}
\textcite{herrmann}

\textcite{herrmann}
\end{document}

Herrmann, Öfele, Schneider, Herdtweck, and Hoffmann (2006)//Herrmann et al. (2006)

So this is expected behaviour of the APA style as implemented by biblatex-apa.

If you want to change that behaviour, have a look at Setting maxcitenames for biblatex-apa and set \apamaxcitenames to 3 in the example.

Note that your two \xpatchbibmacro calls do nothing, because the patched code does not exist in the macros your are patching.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.