0

I am using Texmaker in combination with Miktex and I am writing an article, but Latex can't find my .bib file. The .bib file is located in the same directory as my article latex file. I made .bib files in several ways: by using Mendeley, Jabref and by bibtex itself. In all three the cases I get warnings in Latex: "there were undefined references" and "citation 'citation1' on page 5 undefined".

I guess there is something wrong with my Latex?

Can someone please help me?

I made a MWEB of the report and a MWEB of the bibliography file.

 \documentclass[11pt]{article}

 \usepackage[utf8]{inputenc}

 \usepackage{cite}
 %\usepackage{natbib}

 \begin{document} 
 \pagenumbering{gobble}
 \title{Report}
 \author{Charlie}
 \maketitle
 \newpage
 \mbox{}
 \pagebreak

 \section{Theory}
 Blabla \cite{Gazibegovic2017}

 \pagebreak

 \section{Bibliography}

 \bibliography{biblio.bib}
 \bibliographystyle{plain}

 \end{document}

and the mweb from the bibliography

 @article{Gazibegovic2017,
 author = {Gazibegovic, Sasa. \textit(et al)},
 journal = {Nature},
 number = {7668},
 pages = {434-438},
 title = {{Epitaxy of advanced nanowire quantum devices}},
 volume = {548},
 year = {2017}
 }

I hope this information is sufficient for you to help me.

Kind regards

1

Compiling the following MWEB with

pdflatex document.tex
bibtex document.aux
pdflatex document.tex
pdflatex document.tex

gives the right result.

\documentclass{article}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
    @book{key,
        author = {Author, A.},
        year = {2001},
        title = {Title},
        publisher = {Publisher},
    }
\end{filecontents}

\begin{document}

    \cite{key}

    \bibliographystyle{plain}
    \bibliography{\jobname}

\end{document}
  • A comment to a working example on wikibooks would have had the same amount of information. – Johannes_B Oct 18 '18 at 10:43
  • @Johannes_B that's only to develop my previous comment… Do I have to delete it? – NBur Oct 18 '18 at 11:00
  • Thanks for your response. I try to run my .bib-file to a bibTex, but i get an error message: "couldn't open file name 'biblio1.aux' " , while I saved my bibliography as a .bib-file. I don't know what an .aux-file is and why it says its an .aux-file while I saved it as a .bib-file. – Charlie Oct 18 '18 at 12:00
  • Let say you have source_tex.tex and biblio.bib. You have to run pdflatex source_tex.tex, then bibtex source_tex.aux and twice again pdflatex source_tex.tex. – NBur Oct 18 '18 at 13:20
  • Hi, when I first run report.tex (source_tex.tex) I get the same errors as before: citation 'citation1' undefined. Then I run report.aux (source_tex.aux) I get two error messages and the file seems to have been dissapeared and then I run report.tex (source_tex.tex) twice I get the same errors: 'citation1' undefined. Do you know what is happening? – Charlie Oct 18 '18 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.