0

I am trying to install the isomath package. I am following method 3 here. The command kpsewhich -var-value TEXMFLOCAL gives me /usr/local/share/texmf I put my isomath.sty which I got from CTAN there and then run sudo $(which mktexlsr) which outputs:

mktexlsr: Updating /usr/local/share/texmf/ls-R... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXLIVEDIST... 
mktexlsr: Updating /var/lib/texmf/ls-R-TEXMFMAIN... 
mktexlsr: Updating /var/lib/texmf/ls-R... 
mktexlsr: Done.

then I tried to restart texmaker but I still get the error LaTeX Error: File 'isomath.sty' not found.

Then I tried to do what it says in the README of isomath which says:

Copy/Move/Link isomath.sty to a suitable place in the TDS_ and run texhash, or place it in the current working directory (e.g. for
testing).

I ran texhash whith this output:

texhash: /usr/local/share/texmf: directory not writable. Skipping...
texhash: /var/lib/texmf: directory not writable. Skipping...
texhash: /var/lib/texmf: directory not writable. Skipping...
texhash: /var/lib/texmf: directory not writable. Skipping...
texhash: Done.

As I understand it I did everything right but texmaker is still complaining about not finding isomath, any ideas what I did wrong?

  • isomath is in texlive and miktex so you shouldn't need to get it from ctan by hand like this? tlmgr install isomath ought to install it if it is not installed already. – David Carlisle Oct 18 '18 at 13:19
  • 1
    it looks like your tex installation is installed as root and you ran texhash as a normal user so nothing got updated. but if installing by hand you should install in a separate directory not the main directory that is managed by your package manager. – David Carlisle Oct 18 '18 at 13:20
  • 1
    Quite probably you didn't put isomath.sty in the correct subfolder. But as David already wrote, there should be no need to do this manually anyway. – Ulrike Fischer Oct 18 '18 at 13:23
  • Oh ok thanks I will try tlmgr and if that doesnt work I will try texhash with sudo – Hakaishin Oct 18 '18 at 14:10
  • None of the ideas worked. I tried tlmgr and I get errors(will follow that lead). But also doing sudo texhash didn't work. I don't know why but maybe my linked answer should be changed then, because it does not work for me. – Hakaishin Oct 19 '18 at 10:49
1

I ended up purging texlive and then just installing sudo apt-get install texlive-full which might take up more space then needed, but I had all the packages I needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.