3

I recently got back reviews for a paper I submitted eight months ago. Upon opening my file, I discovered it wouldn't compile properly anymore. After some troubleshooting, I narrowed it down to the linguistic tree I drew using the Forest package. I tried compiling the tree in a dummy document. Then I tried a dummy tree in a dummy document. But as soon as I put in \begin{forest}\end{forest}, the same error pops up

(TeX capacity exceeded, sorry [parameter stack size=120]).

MWE

\documentclass{article}
\usepackage[linguistics]{forest}    

\begin{document}

\begin{forest}
[CP[C][IP[I][VP[V][NP]]]]
\end{forest}

\end{document}

As I said, I haven't worked on the document in quite a while, but it used to compile with no issues. If I paste my MWE in a web-based Latex editor (overleaf), it compiles without issue. Perhaps this is an issue with Texpad? Has there been an update causing this incompatibility?

I have searched for similar issues, but as yet to no avail.

  • This is probably unrelated to your editor. I would rather suspect different version of packages. Compare the .log file from your computer to the one from overleaf and see if any of the packages have a different version. – user36296 Oct 18 '18 at 14:30
  • btw: your MWE compiles fine for me with up-to-date pdflatex from texlive2018. – user36296 Oct 18 '18 at 14:32
  • @samcarter check the last line of the log:-) – David Carlisle Oct 18 '18 at 14:50
0

If you're using the TexPad editor, make sure to use the external typesetter, not TexPad's internal one. That will not typeset for me, but the external one will.

3

If I run the example with texlive it completes without error but the end of the log says

 133i,9n,160p,1577b,1258s stack positions out of 5000i,500n,10000p,200000b,80000s

so it used 160 slots in the parameter stack. You show you are using a tex with a stack of size 120 which is too small. (as shown above current texlive defaults to 10000)

  • Switching from the internal typesetter to the external one in Texpad did the trick! – Emma Oct 22 '18 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.