0

I am trying to convert a .tex document from \documentclass{article} to \documentclass[final]{aomart}.

When I try to compile the document, I get the following error message:

line 17 Option clash for package hyperref. \usepackage

The script is:

1  \documentclass[final]{aomart}
2  \usepackage[utf8]{inputenc}
3  \usepackage[title]{appendix}
4  \usepackage{parskip}
5  \usepackage{amsmath}
6  \usepackage[english]{babel}
7  \usepackage{pgfplots}
8  \usepgflibrary{arrows}
9  \usetikzlibrary{arrows}
10 \pgfplotsset{compat=1.16}
11 \usepackage{tikz}
12 \usepackage{amssymb}
13  \usepackage{cancel}
14  \usepackage{float}
15  \usepackage[section]{placeins}
16  \usepackage[hidelinks]{hyperref}
17  \usepackage{enumerate}
18  \newtheorem{theorem}{Theorem}[subsection]
19  ...

I tried removing \usepackage[hidelinks]{hyperref} or \usepackage{enumerate}, but I get other messages.

How should I fix this issue?

Update

Here is the MWE:

\documentclass[final]{aomart}
\usepackage{pgfplots}
\usepackage[hidelinks]{hyperref}
\usepackage{enumerate}
\begin{document}
    xxx
\end{document}
  • Can you make a minimal working example (MWE)? Please also remove the line numbers, if we are going to work on a solution for your problem, we would have to painstakingly remove them before we could compile a document. – user36296 Oct 19 '18 at 10:16
  • the package hyperref with rare exception should be loaded last. please provide complete but small document which we can test and see, what is the problem. – Zarko Oct 19 '18 at 10:19
  • Sorry. I have added a MWE. – Jérôme Verstrynge Oct 19 '18 at 10:26
  • why you need option hidelinks? without it your example work fine. also links are not visible, however ithey are active. – Zarko Oct 19 '18 at 10:32
  • @Zarko: It's because I followed this advice: tex.stackexchange.com/a/12408/165510. – Jérôme Verstrynge Oct 19 '18 at 10:35
3

The aomart class already loads hyperref with options, thus you get an option class if you ask for other options.

If really needed, then use

\hypersetup{
  hidelinks
}

in your preamble instead. You can do this with most hyperref options (if not all).

BTW: enumitem is probably more recommended to use for lists than the old enumerate package

  • I removed \usepackage[hidelinks]{hyperref} and modified the 1st line to \documentclass[hidelinks,final]{aomart}. The issue is gone. – Jérôme Verstrynge Oct 19 '18 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.