1

I am writing .bib files for citations. I wanted to add commas but I am getting periods in Bibliography in my Report as shown below:

Jun Rao. The Apache Software Foundation. Apache --- Architecture and Partitions. https://data-flair.training/blogs/kafka-topic-architecture/. 2018.

@misc{The    Apache  Software    Foundation,
author = "Jun Rao",
title = "{Apache]} --- {A}rchitectue and Partitions ",
year = "2018",
howpublished = {\url{https://data-flair.training/blogs/kafka-topic- 
architecture/}},
}

How do I change my bib file to have commas instead of a period in between the entities?

4
  • 1
    Your bibliography style decides the format of the bibliography output. It decides whether to use commas or full stops, whether to use italics, quotation marks, ..., it also decides the order of the fields. Your .bib file has no say in this. Please tell us what style you use in a short example document (tex.meta.stackexchange.com/q/228/35864)
    – moewe
    Oct 21, 2018 at 5:16
  • With biblatex the answer to your question would be \renewcommand*{\newunitpunct}{\addcomma\space}, but it is doubtful that you actually use biblatex. With BibTeX the answer strongly depends on the style you use and might be more complicated. So please tell us which bibliography package/system you use (cite, natbib, jurabib, biblatex, ...) and which style you use (the argument to \bibliographystyle with BibTeX, the value of the style option in biblatex).
    – moewe
    Oct 22, 2018 at 7:39
  • Please tell us which bibliography package and which style you use. Without that information we won't be able to help you properly. If there is no edit here in due time I will vote to close this question as unclear what you are asking.
    – moewe
    Oct 24, 2018 at 16:54
  • Any news here? If there are no new developments here soon, I will vote to close this question as unclear.
    – moewe
    Oct 28, 2018 at 12:45

0

Browse other questions tagged .