1

I am using reledpar/reledmacto format a 'synopsis' in two columns and I am seeing occasional (apparently random) extra blank lines where there is no blank line/break in the source text. You can see the blank lines in the following example: enter image description here

And this is the code of my .tex-file:

    \documentclass[oneside, 8pt]{extarticle}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[a4paper, left=15mm, right=35mm]{geometry}
\usepackage[german]{babel}
\usepackage{alltt}
\usepackage{relsize}
\usepackage{subscript}
\usepackage[normalem]{ulem}
\usepackage{fontawesome}
\usepackage{reledmac}
\usepackage{reledpar}

\setlength \parindent{0pt}
\rightnoteupfalse
\linenummarginR{left}
\pagenumbering{gobble}
\title{Does not matter}
\begin{document}
\begin{pairs}
\begin{Leftside}
\beginnumbering{}

\pstart{}
first ~\\
\skipnumbering{}
\pend{}


\pstart{}
this is a line\pend{}
\pstart{}
another line\pend{}
\pstart{}
line \pend{}
\pstart{}
just a line\pend{}
\pstart{}
and a line\pend{}
\pstart{}
oh it's a line~\\
\skipnumbering{}
\pend{}

\pstart{}
just a line\pend{}
\pstart{}
and a line\pend{}
\pstart{}
oh it's a line~\\
\skipnumbering{}
\pend{}

\pstart{}
just a line\pend{}
\pstart{}
and a line\pend{}
\pstart{}
oh it's a line~\\
\skipnumbering{}
\pend{}




\endnumbering{}
\end{Leftside}
\begin{Rightside}
\beginnumbering{}

\pstart{}
a heading\\
\skipnumbering{}
\pend{}


\pstart{}
\pend{}
\pstart{}
\pend{}
\pstart{}
\pend{}
\pstart{}
\pend{}
\pstart{}
\pend{}
\pstart{}
~\\
\skipnumbering{}
\pend{}


\pstart{}
just a line\pend{}
\pstart{}
and a line\pend{}
\pstart{}
oh it's a line~\\
\skipnumbering{}
\pend{}

\pstart{}
just a line\pend{}
\pstart{}
and a line\pend{}
\pstart{}
~\\
\skipnumbering{}
\pend{}

\endnumbering{}
\end{Rightside}
\end{pairs}
\Columns{}
\end{document}

I think it might be a similar problem like in this post, but i am not using the setspace package, so i think it's a different problem. Any ideas how to solve it?

  • why do you add {} after \pend and \pstart. It is not required, and make the reading of the code harder. – Maïeul Oct 21 '18 at 21:46
0

The problem is cause by your ~\\ on the right side. That makes your side longer. And reledpar make the left side to the same height.

Consider this code, which I simplified from your code:

  • no more superfious {}
  • no more \skipnumbering
  • 1 put line number every line, to debug
  • no class or package not neeeded for a MWE

Here the code

\documentclass[oneside, ]{book}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[a4paper, left=15mm, right=35mm]{geometry}
\usepackage[german]{babel}
\usepackage{reledmac}
\usepackage{reledpar}

\setlength \parindent{0pt}
\rightnoteupfalse
\firstlinenum*{1}
\linenumincrement*{1}
\linenummarginR{left}
\pagenumbering{gobble}
\title{Does not matter}
\begin{document}
\begin{pairs}
\begin{Leftside}
\beginnumbering

\pstart
first ~\\
\pend


\pstart
this is a line
\pend
\pstart
another line
\pend
\pstart
line
\pend
\pstart
just a line
\pend
\pstart
and a line here the problem
\pend
\pstart
oh it's a line~
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line
\skipnumbering
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line~\\
\skipnumbering
\pend




\endnumbering
\end{Leftside}
\begin{Rightside}
\beginnumbering

\pstart
a heading\\
\pend


\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
~\\
\pend


\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line~\\
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
~\\
\pend

\endnumbering
\end{Rightside}
\end{pairs}
\Columns
\end{document}

That produce the following output Output

Has you can see the extra spaces on right and left side are the same, and correspond to you ~\\ on right side.

If I delete it, all is ok

\documentclass[oneside, ]{book}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[a4paper, left=15mm, right=35mm]{geometry}
\usepackage[german]{babel}
\usepackage{reledmac}
\usepackage{reledpar}

\setlength \parindent{0pt}
\rightnoteupfalse
\firstlinenum*{1}
\linenumincrement*{1}
\linenummarginR{left}
\pagenumbering{gobble}
\title{Does not matter}
\begin{document}
\begin{pairs}
\begin{Leftside}
\beginnumbering

\pstart
first ~\\
\pend


\pstart
this is a line
\pend
\pstart
another line
\pend
\pstart
line
\pend
\pstart
just a line
\pend
\pstart
and a line here the problem
\pend
\pstart
oh it's a line
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line
\pend




\endnumbering
\end{Leftside}
\begin{Rightside}
\beginnumbering

\pstart
a heading\\
\pend


\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
\pend
\pstart
\pend


\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
oh it's a line
\pend

\pstart
just a line
\pend
\pstart
and a line
\pend
\pstart
\pend

\endnumbering
\end{Rightside}
\end{pairs}
\Columns
\end{document}

enter image description here

The question is "why do you add ~\\? " I am sur you have a good reason to do that, but it is not a good idead due to reledmac internal mecanism. What do you expect? I think we have a solution inside reledmac to your problem.

  • Thank you very much for your answer. The intention behind using ~\\ was to create spacing between two paragraphs. But it's probably a better solution to work with either \stanza or \vspace as parameter for \pstart. – B Polit Oct 22 '18 at 8:30
  • yes, it is better to use \pstart[\stanta]. and remember that the paragraph are synchronized. – Maïeul Oct 22 '18 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.