3

After I updated TeXLive 2018 yesterday, I got the following error message when I use XeLaTeX to compile my file.

xelatex.exe> Runaway argument?
xelatex.exe> 76543210\q_stop newline - 'bold' (bx/n) with NFSS spec.: <->s*[0.9999\ETC.
xelatex.exe> ! File ended while scanning use of \__iow_wrap_end_chunk:w.
xelatex.exe> <inserted text> 
xelatex.exe>                 \par 

After checking the code, I found this error happens with TeXLive and MiKTeX with XeLaTeX. When I switch to LuaLaTeX or use \setmathfont to set the font, the error disappear. The following is the minimal example in my computer. Does anyone know what might cause this? Or this is a bug in unicode-math? Thanks : )

%% LyX 2.3.1-1 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[11pt,twoside]{article}
\usepackage{fontspec}

\makeatletter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
\newlength{\lyxlabelwidth}      % auxiliary length 

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\usepackage{unicode-math}
%\setmathfont{texgyrepagella-math.otf}

\makeatother

\begin{document}
~
\end{document}

closed as off-topic by egreg, Stefan Pinnow, TeXnician, David Carlisle, Mensch Oct 21 '18 at 17:56

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It is a bug in l3kernel. It has already been updated on ctan but miktex will need to catch up with it. – Ulrike Fischer Oct 21 '18 at 16:18
  • You can download http://mirrors.ctan.org/install/macros/latex/contrib/l3kernel.tds.zip from ctan, unpack it somewhere outside miktex and attach its root as a new root in the miktex console. That should keep you going until miktex installs the new version. – Ulrike Fischer Oct 21 '18 at 16:22
  • No error with the just updated l3kernel. It was a bug that has been removed. – egreg Oct 21 '18 at 16:32
  • 4
    I'm voting to close this question as off-topic because the issue is solved updating the TeX distribution – egreg Oct 21 '18 at 16:32
  • 1
    To Ulrike Fischer, I have followed your instruction to add l3kernel.tds as a new root directory, but I still get the same error. May I confirm how to make sure MikTeX use the new l3kernel.tds, and not the original one? Thanks : ) – Yu-Tsung Tai Oct 23 '18 at 2:13

Browse other questions tagged or ask your own question.