Please help! They have updated my computer to Windows 7, and I have tried to reinstall MiKTeX2.9 and TeXnicCenter. When I run a LaTeX program, it tries to install 412 files from CTAN, and I get the error:

pdflatex.exe: A timeout was reached while receiving data from the server

And then I get a LaTeX error that pgfcore.sty was not found.

Is it some permissions problem with Windows 7? I have administrative privileges that I could use, but I don't seem to be prompted for my password...

This is driving me crazy! Any help is much appreciated.

  • Hi Fiona, welcome to TeX.sx! I removed the sign-off, as your user name and badge are automatically included anyway.
    – qubyte
    Commented Feb 24, 2012 at 17:33
  • Just as a single data point: The combination of Windows 7, MiKTeX 2.9 and TeXnicCenter (Alpha 4) is running nicely here. Try Ulrike's suggestions, if they are not enough I would completely remove MiKTeX and reinstall the full version.
    – Alexander
    Commented Feb 24, 2012 at 18:47

1 Answer 1


I doubt that it is due to permissions problems. The message says "timeout" and this indicates a connection problem. It could mean that the server/repository you are trying to use is simply down (that happens). But it also could be due to a proxy or a VPN-tunnel (I can't install packages on my work PC when I'm connected to our intranet).

Try to install the pgf-package directly with the package manager. Try different repositories (menu repository). If both doesn't work: Get from CTAN the files


and perhaps other package from systems/win32/miktex/tm/packages/. Put them all in an empty folder outside your miktex. Then use the package manager to install them by using the folder as "local repository".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .