0

The following code

\documentclass{article} 
\usepackage{lipsum}

\begin{document} 
\lipsum 
\end{document}

all of a sudden gives the following error in TexStudio on Ubuntu 18.04 with TexLive:

File `lipsum.sty' not found. \usepackage

BUT, I can successfully compile from bash:

$ latex top.tex

I'm thinking this might be because I removed LatexDraw using:

apt-get remove --purge latexdraw
apt-get autoremove

I've tried debugging this, so I list the outputs of some of the commands I ran:

  • which tex gives /usr/local/texlive/2018/bin/x86_64-linux/tex
  • kpsewhich -var-value=TEXMFHOME gives /home/me/texmf, a non-existing directory
  • kpsewhich lipsum.sty gives /usr/local/texlive/2018/texmf dist/tex/latex/lipsum/lipsum.sty
  • Inside TexStudio, Build/Commands ($PATH) reads /usr/local/texlive/2018/bin/x86_64-linux

Any help is appreciated!

  • Do you start TeXStudio from a terminal (via texstudio)? – Paul Gaborit Dec 19 '19 at 1:30
0

I restarted my computer and it went back to working normally. 10 minutes later, the problem is back...


Before edit:

Once again, the solution is: restart your computer. Anyone who has a real solution or followup is welcome to post an answer.

  • Did you try just logging out and in again? Linux rarely need you to reboot. How exactly do you normally start texstudio. – daleif Oct 24 '18 at 17:05
  • @daleif Yes I did, unfortunately. Must just be this supergreat Ubuntu 18.04 that I got! – ToniAz Oct 24 '18 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.