I'm running a miktex installation on an airgapped computer and have been installing latex packages manually. I've installed the newtx fonts but miktex is giving the following error:

INFO miktex-makemf - starting with commmand line: "[...] \x64\miktex-makemf.exe" -- verbose rfxlri-alt
FATAL miktex-makemf - The rfxlri-alt source file could not be found.

Additionally, looking at miktex-makepk.log:

INFO  miktex-makepk - starting with command line: "C:\Users\admin\AppData\Local\Programs\MiKTeX 2.9\miktex\bin\x64\miktex-makepk.exe" --verbose rfxlri-alt 600 600 magstep(0.0)
INFO  makepk - Trying to make PK font rfxlri-alt at 600 DPI...
INFO  makepk - The METFAONT mode is: ljfour
INFO  makepk - Running miktex-makemf.exe...
INFO  makepk - running: miktex-makemf.exe --verbose rfxlri-alt
INFO  makepk - Running miktex-ttf2pk.exe...
INFO  makepk - running: miktex-ttf2pk.exe -q -t rfxlri-alt
FATAL miktex-makepk - PK font rfxlri-alt could not be created.

I've checked that newtx has been installed. I've Refreshed FNDB. It appears to be looking for the source file of rfxlri-alt, but font/source doesn't contain this and the packages I can find don't have a copy: https://ctan.org/tex-archive/fonts/newtx

hacking at the file, the error only occurs when there is a mathematical symbol in the text, such as

$>$
up vote 0 down vote accepted

I ran updmap from the command line and this error disappeared

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.