After struggling to make to memoir class work again I suddenly cannot update MikTeX. I get the following error message:

Invalid argument: path="C:\Users\pr\AppData\Local\Temp\mik49805\forms16be.tpm"

The error report also contains the following information:

MiKTeX: 2.9
OS: Windows 8.1 Pro, 64-bit, build 9600
SharedSetup: yes
PathOkay: yes
SystemAdmin: yes
RootPrivileges: yes
Root0: C:\Users\pr\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\pr\AppData\Local\MiKTeX\2.9
Root2: C:\ProgramData\MiKTeX\2.9
Root3: C:\Program Files\MiKTeX 2.9
UserInstall: C:\Users\pr\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\pr\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\pr\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9
Invokers:

What can I do to make it work again?

  • 1
    Have you tried to change the repository? Please descibe better what you did before the error occurs ... – Kurt Oct 25 at 18:44
  • I would close MiKTeX if open go to your temp directory as above and delete all folders/files that say MiK….. (and any other really old files or file/folders that look like TeX dross, just don't try to delete FXSAPIDebugLogFile) go back to MiKTeX console and refresh file name database then if that's your answer you are allowed to answer your own question. If it doesn't work tell us thats what you tried by adding to your question – KJO Oct 25 at 19:20
  • I still cannot make it work - each time I check for updates I get a different error message - at one instance: – priis Oct 25 at 21:22
  • Invalid argument: path="C:\Users\pr\AppData\Local\Temp\mik66191\biblatex-apa.tpm" and next time Invalid argument: path="C:\Users\pr\AppData\Local\Temp\mik7945\biblatex-abnt.tpm" – priis Oct 25 at 21:23
  • Did you close MiKTeX and delete all visible traces in your temp directory ? NOTE I was also getting issues with MiKTeX which happens frequently when main server goes down (a disadvantage of on the fly package downloads) hence the older ProTeX version which avoided such issues, but have just tested again am updating as I write so please refresh named database and retry updates in console – KJO Oct 25 at 22:21

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.