1

I've read this question: Vertical space in lists but neither solution offered there works for me. When I add this:

\usepackage{enumitem}
\setitemize{itemsep=-10pt,parsep=-10pt,topsep=-10pt,partopsep=-10pt}

Or any combination of the above lots of different things get affected, but it makes absolutely no difference to how enumerate environments are rendered.

However, when I add \setlength\itemsep{-10pt} to the enumerate environment, then it does change the itemsep length.

Unfortunately, the LaTeX code is generated, and I cannot alter the generator to insert the setlength command. Is there any other way to deal with this problem? (Renaming environment isn't also an option for the same reason).

  • Could you be more clear on your problem? Maybe a piece of code would help. – Brasil Oct 27 '18 at 19:59
  • Oh, nevermind, but for others who may run into a similar issue: another code was using \setenumerate{leftmargin=*}, which prevented modifying other properties of enumerate. After the timer is up, I'll update the post to reflect this. – wvxvw Oct 27 '18 at 19:59
2

The exact syntax, as documented by enumitem, should be

usepackage{enumitem}
\setlist[enumerate]{itemsep=-10pt,parsep=-10pt,topsep=-10pt,partopsep=-10pt}

or, for specific list levels, something like

\setlist[enumerate,2]{itemsep=-10pt,parsep=-10pt,topsep=-10pt,partopsep=-10pt}

for an enumerate list of level 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.