My problem is that the diff.tex file which I generate, after running latexdiff, is empty/blank.

  • I have installed Perl 5, version 28.
  • I installed latexdiff from the miktex package manager
  • I installed Strawberry Perl for Windows 64 bit.
  • In the Perl Command Prompt, I changed the working directory to where my original.tex and final.tex files were saved
  • In the Perl Command Prompt, I ran the code: latexdiff original.tex final.tex > diff.tex
  • In my working directory, the diff.tex file exists but it is completely blank/empty
  • Additionally, two errors appear in the Perl Command Prompt:
    1. The first error says "latexdiff: the script engine could not be found"
    1. The second error says "latexdiff: Data: scriptEngine='perl.exe' "
  • I've tried to fix this by downloading latexdiff from CTAN and then copying the files into the perl bin folder. But this fix hasn't worked.

Is there a quick fix for this?

  • It sounds like latexdiff is not even running, because somehow the system does not figure out he should use perl to run it. Unfortunately I don't know Strawberry Perl so cannot help you there. But before you run latexdiff on files, you could check that at least it gets executed by running latexdiff -h – frederik Oct 30 at 19:47

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.