2

I foolishly updated TeXShop recently and I now have the following problem.

Previously, I could highlight text in the editor with the cursor and start typing to overwrite it. Now if I highlight some text to replace "abc" and I start typing something that requires holding shift down, such as "$def...", I end up with "$abc$def...". In other words, the highlighted text is enclosed with $...$ and then the rest of the text is inserted directly afterwards.

How can I get back to the previous setting of simply overwriting the highlighted text?

  • Welcome to the site TeX.SE. – Sebastiano Oct 29 '18 at 12:54
2

Got to the Editor tab of TeXShop->Preferences and uncheck Editor Can Add Brackets at the bottom of the Editor section of that pane.

  • By the way, it has nothing to do with the Shift key but rather with delimiters that are generated in pairs when there is a selection of 3 or more characters; i.e., typing $ with that selection automatically surrounded the selection with a matching set of $. – Herb Schulz Oct 29 '18 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.