3

I am creating a beamer presentation with references, listed as fullcites.

Some of those entries are taking too much space on the slides because the spacing between lines (that belong to the same reference!) are sometimes too large. I'd like to make it smaller, but failed with every single attempt.

Here is the example code:

\documentclass{beamer}
\usepackage[backend=biber]{biblatex}

\begin{filecontents}{\jobname.bib}
@InProceedings{identifier1,
  Title                    = {Some Awesome Title},
  Author                   = {Some Author and Another Author},
  Booktitle                = {Some Book about the Future},
  Year                     = {2042},
  Pages                    = {1--42}
}

@InProceedings{identifier2,
  Title                    = {Some So-So Title},
  Author                   = {First Author and Second Author},
  Booktitle                = {An okay Booktitle},
  Year                     = {2000},
  Pages                    = {1--100}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}

\begin{frame}
\begin{footnotesize}
  \fullcite{identifier1}\\
  \fullcite{identifier2}
\end{footnotesize}
\end{frame}

\end{document}

And here how it looks like:

enter image description here

Here you can observe two things:

(1) The spacing of the first citation is good (although I'd still like to know how to save even more space here (maybe 1mm or .5mm), because space is really a big issue) and

(2) The spacing of the second entry is not okay: the space between those lines is really too large. I'd thus like to know how to reduce the distance between those lines (best would be individually for each entry).

6

If you end your fullcites with a paragraph the correct spacing of \footnotesize is applied:

\documentclass{beamer}
\usepackage[backend=biber]{biblatex}

\begin{filecontents}{\jobname.bib}
@InProceedings{identifier1,
  Title                    = {Some Awesome Title},
  Author                   = {Some Author and Another Author},
  Booktitle                = {Some Book about the Future},
  Year                     = {2042},
  Pages                    = {1--42}
}

@InProceedings{identifier2,
  Title                    = {Some So-So Title},
  Author                   = {First Author and Second Author},
  Booktitle                = {An okay Booktitle},
  Year                     = {2000},
  Pages                    = {1--100}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}

\begin{frame}

\begingroup
    \footnotesize
  \fullcite{identifier1}\par
  \fullcite{identifier2}\par
\endgroup
\end{frame}

\end{document}

enter image description here

If you need more fine control of the distance between the lines, you can use \fontsize{<size>}{<skip>}\selectfont instead of \footnotesize to define the size and the baselineskip separately.

5

@samcarter already suggested an interesting approach (you could also use a blank line in place of \par there). Here is another.

You could use biblatex's begentry macro, which serves as a nice hook for things to be applied to the full entries:

\documentclass{beamer}
\usepackage[backend=biber]{biblatex}

\begin{filecontents}{\jobname.bib}
@InProceedings{identifier1,
  Title                    = {Some Awesome Title},
  Author                   = {Some Author and Another Author},
  Booktitle                = {Some Book about the Future},
  Year                     = {2042},
  Pages                    = {1--42}
}

@InProceedings{identifier2,
  Title                    = {Some So-So Title},
  Author                   = {First Author and Second Author},
  Booktitle                = {An okay Booktitle},
  Year                     = {2000},
  Pages                    = {1--100}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\renewbibmacro*{begentry}{\footnotesize}

\begin{document}

\begin{frame}

\fullcite{identifier1}

\fullcite{identifier2}

\end{frame}

\end{document}

That's more practical in my view, for you only have to do it once in your preamble, not bothering with setting \footnotesize at every citation (separates content from presentation, and so on).

enter image description here

1
  • Thank you for this elegant solution. For me, it did not work, but I assume this is only due to side effects of the various other packages that I load (I was too lazy to find out which ones, so I just went with the other). Anyway, thank you! – Prof.Chaos Nov 3 '18 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.