0

I'm running latex files on my device. These are the first few lines of the file:

\documentclass[sigconf, anonymous, review]{acmart}
\usepackage{adjustbox}
\usepackage{array,booktabs}
\usepackage{amsmath, amsfonts, amsthm}
\usepackage{amssymb}
\usepackage{bm}
\usepackage{graphicx}
\graphicspath{{./}{Charts/}}
\usepackage{subcaption}
\usepackage{tikz}
\usepackage{fullpage}
\usepackage{hyperref}
\usepackage{xspace}

\usepackage{algorithm}
\usepackage{todonotes}
\usepackage[noend]{algpseudocode}

The problem is when I run it I get red line numbers only in the first page. But my colleagues get it on every page. We use the exact same latex file and also the same acmart.cls (latest one) file on the local directory. I also had this problem before in another case. The conference information for others showed up in all the pages, and for mine it was only in the first page. I don't know what's the problem. I'm running this command: 'pdflatex filename.txt'

My latex version is: 'pdfTeX 3.14159265-2.6-1.40.19 (TeX Live 2018) kpathsea version 6.3.0'

Could someone please tell me what causes the problem? Thank you.

3
  • 1
    With your example my simple document using \lipsum doesn't show line numbers nowhere... So, please create an example (compilable with everything needed) that shows your actual problem. Also I don't know what the footnotes tag has to do with your question.
    – koleygr
    Nov 1 '18 at 23:38
  • The conference information should shown up as header notes in all the pages (as it does when others run it). But on my device it only shows up in the first page.
    – Kat
    Nov 1 '18 at 23:47
  • The problem in my test was that I had no maketitle command because I supposed doesn't really needed... But it is needed for this functionality. See my answer
    – koleygr
    Nov 1 '18 at 23:50
1

I found out that removing the package fullpage solves the problem:

\documentclass[review]{acmart}
\usepackage{adjustbox}
\usepackage{array,booktabs}
\usepackage{amsmath, amsfonts, amsthm}
\usepackage{amssymb}
\usepackage{bm}
\usepackage{graphicx}
\graphicspath{{./}{Charts/}}
\usepackage{subcaption}
\usepackage{tikz}
%\usepackage{fullpage} Commented out

\usepackage{xspace}

\usepackage{algorithm}
\usepackage{todonotes}
\usepackage[noend]{algpseudocode}

\usepackage{hyperref}

\title{test}
\author{test}
\usepackage{lipsum}
\begin{document}
\maketitle


\lipsum[1-15]
\end{document}

Also moved the hyperref to be loaded last.

Consider using geometry package with the appropriate settings (but better just don't touch this documentclasse's features and just remove it)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.