0

I have set some text shortcuts in Mac OS. I am not talking about the autocompletion file specific to texshop (which works fine), but about something you can set in Mac OS prefs>keybord>text and can be used in all the applications.

For instance if I type "mcal" and then space, it should automatically transform into "\mathcal ", without me hitting esc, tab or anything.

The weird thing is that these shortcuts work if I type them in textedit. The even weirdest thing is that it was working yesterday (it was the first time I was setting it up), and I don't remember I have changed anything.

I have closed and restarted everything, checked and unchecked texshop preferences about completion, etc...but it just does not work anymore.

Anyone knows if there is some setting to change for these shortcuts to work?

Thanks

1

Make sure you check Edit->Substitutions->Text Replacement which will stick once checked.

  • Indeed it answers it. There are actually 3 places to check: system preferences, Texshop preferences, and this special item to chek in the menus. Thanks! – kaleidoscop Nov 14 '18 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.