I'm trying to compile a mixed English and Hebrew document. When I try to compile (using WinEDT btw) I get an error massage saying-

Sorry, but miktex-makemf did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

Running miktex-hbf2gf.exe...

hbf2gf (CJK ver. 4.8.4)

Couldn't open `jerus.cfg'

Sorry, but miktex-maketfm did not succeed.

The log file hopefully contains the information to get MiKTeX going again:


! Font LHE/cmr/m/n/10=jerus10 at 10.0pt not loadable: Metric (TFM) file not fou
<to be read again> 
l.6 \select@language{hebrew}

I'm using WinEDT, MIKTeX 2.9, culmus is installed. Things Iv'e tried:

  1. running updmap --admin from the command prompt.
  2. running updmap --force from the command prompt.
  3. updating MIKTeX.
  4. uninstalling and re-installing MIKTeX.

My code is something like

\usepackage[left=2.5cm, right=2.5cm, top=3cm, bottom=2.5cm]{geometry}

\rhead{\emph{Writer's name}}
\rfoot{Page \thepage}

    {\LARGE Institute name \par}
    {\LARGE Academic department \par}
    {\Large Bla Bla Bla\par}
    {\huge\bfseriesטקסט בעברית\par}
    {\huge\bfseries Research Titlel\par}
    {\Large\itshape Writer's Name\par}
    Advisor: by\par
    Prof.~Advisor \textsc{Surname}
% Bottom of the page
  • 1
    culmus is either not installed, not up-to-date or you are not using it correctly. Be aware that even with culmus not everything works as it eg doesn't contain suitable utf8 support. – Ulrike Fischer Nov 2 '18 at 17:06
  • @UlrikeFischer, i think culmus is installed properly. Hebrew worked ok prior to MIKTeX update. Iv'e also downloaded it again today and re-installed it. Didn't work. – U.Nusbaum Nov 2 '18 at 20:08

You should add \usepackage{culmus} otherwise it tries to load the old ivritex font (Jerusalem, etc.).

Alternatively, switch to xetex, things work match better there. See this example.

I'm advocating xetex even though i maintained culmus-latex

  • Hi Guy, culmus is already loaded. Switching to xetex also didn't work. – U.Nusbaum Nov 5 '18 at 8:23
  • Have you specified a Hebrew font for Xetex other than the default? – Guy Nov 6 '18 at 14:26
  • No I did not. I think somethink is wrong with culmus/miktex installation but I can't figure out what is it – U.Nusbaum Nov 6 '18 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.