2

this is my first time here because I need a help about main font and math font.

When I use the standard font, there isn't problem, but, when I change the main font, for example "Gill Sans MT", the font of the operators change with the main font. I search on this site a solution without success.

Is there something to force the default math font for the operators?

This is a sample code:

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Gill Sans MT}
\usepackage{amsmath,amssymb}
\usepackage{mathtools}
\begin{document}
un po' di testo...

\vspace{2em}
$\sin\alpha$ $sin\,\alpha$ $\mathrm{sin}\,\alpha$

\vspace{2em}
un po' di testo
\end{document}

And this is the result:

enter image description here

Thanks for the future help

  • 5
    Welcome to TeX SX! Simply load fontspec with the no-math option. – Bernard Nov 3 '18 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.