2

I'm working in a report and I can't make the references work the way I want to. My main problem is that, in the references section, the number in square brackets at the beginning of the reference doesn't show up. I've already looked up over the Internet for possible solutions, but none of them worked. I would be very grateful if someone could help me out. Following, it's the part of my code I consider relevant:

\documentclass[12pt,a4paper]{article}
\usepackage[utf8]{inputenc}
\usepackage[spanish]{babel}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{imakeidx}
\usepackage{graphicx}
\usepackage{apacite}
\usepackage{xcolor}

\usepackage[sort, numbers]{natbib}
\usepackage{hyperref}  % Hyperlinks bib references.
\begin{document}

(...)

...esfera del hardware \cite{ocp} \cite{ocp2} \cite{ocp3}.

\bibliographystyle{unsrtnat}
\bibliography{referencias}

\end{document}

And here is my .bib file

@misc{ocp,
 number = {1},
 author = {OPC},
 title = {About Open Compute Project},
 url = {https://www.opencompute.org/about},
 year = {2018},
 note = {Último acceso: 03-11-2018}
}

@misc{ocp2,
 number = {2},
 author = {OPC2},
 title = {About Open Compute Project 2},
 url = {https://www.opencompute.org/about},
 year = {2018},
 note = {Último acceso: 03-11-2018}
}

@misc{ocp3,
 number = {3},
 author = {OPC3},
 title = {About Open Compute Project 3},
 url = {https://www.opencompute.org/about},
 year = {2018},
 note = {Último acceso: 03-11-2018}
}

Here is the output for my references section

As you can see there is no number between square brackets in the references. That's what I'd like to fix. Thank you.

  • 2
    If I try, I get the numbers. Please, let us know what document class you're using, which might change something about the choice of the options to natbib. – egreg Nov 3 '18 at 23:04
  • I've already added the document class and the citations in the text. I use an article class (I always use that class, to be honest) and \cite{}. – anmomu Nov 4 '18 at 18:39
  • 1
    @anmomu apacite is the culprit, of course. – egreg Nov 4 '18 at 22:48
3

The problem is apacite that defines its own style for the references, using the author-year system and so omitting the numbers next to the references.

By the way, number is a BibTeX field completely unrelated to bibliography item numbers and rather refers to numbers of a serial publication such as a journal; it is ignored in a @misc entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.