3

I want to compile a letter in French using KOMAScript (2018/03/30 v3.25) and choosing 'french' as an option for babel. When I am running the following minimal example using TeXLive 2018 on a Mac,

\documentclass[parskip=full+]{scrlttr2}
\usepackage[french]{babel}
\begin{document}
\begin{letter}{Destinataire}
\opening{Bonjour,}
blablabla
\end{letter}
\end{document}

I am getting the following error messages:

(/usr/local/texlive/2018/texmf-dist/tex/generic/babel/txtbabel.def))

-29- Attention : le moteur TeX en utilisation avec des fontes CM

(comme dans ce format TeX) est insuffisant pour la cÈsure

des mots accentuÈs (comme en franÁais).

-52- Erreur : e-french package ne fonctionne pas avec une classe de document si minimaliste, dÈsolÈ !

) ) ) )

(\end occurred when \ifx on line 459 was incomplete)

(\end occurred when \ifx on line 459 was incomplete)

No pages of output.

Is there any known incompatibility between the french babel option and scrlttr2 and what needs to be done to use scrlttr2 with the french option ? I don't have any issues using english or german as options.

  • 2
    The example compiles fine (i.e. without error) for me, if I add \usepackage[T1]{fontenc} I can even get rid of the only warning (only if you use pdfLaTeX, with LuaLaTeX or XeLaTeX that should not be necessary). The output looks fine. Is your system up to date (your KOMA script is recent, but maybe other packages are outdated), i.e. did you check for updates? – moewe Nov 5 '18 at 15:41
  • The KOMA-Script manual states (p. 499): “If you use the babel package to switch to french, problems can occasionally occur. With babel, however, you can usually deactivate changes to a language in a targeted manner.” I’m not sure if this helps. – Ruixi Zhang Nov 5 '18 at 15:49
  • 3
    looks as if your system is finding e-french, instead of french. Do you have a full texlive? Is it up-to-date? – Ulrike Fischer Nov 5 '18 at 15:50
  • perhaps try option frenchb in place of french and report if it changes something. – user4686 Nov 5 '18 at 16:35
2

Error messages like yours often happened, when e-french has been used, because e-french never was compatible with KOMA-Script and several other non-standard classes. But for several versions of babel it does not use any code of e-french and the babel-french manual even notes, that french.cfg of e-french is incompatible with babel-french. So if you still have an old installation of e-french or an old french.cfg of e-french you should remove them.

And maybe you should update your TeX Live installation. With an up-to-date KOMA-Script 3.26b and babel 3.27 (last available version for TeX Live 2018) with french.ldf 3.5d or with babel 3.29 (current release on CTAN or in TeX Live 2019) and french.ldf 3.5e no such error occurs.

With pdflatex their is only a warning message:

Package french.ldf Warning: OT1 encoding should not be used for French.
(french.ldf)                Add \usepackage[T1]{fontenc} to the preamble
(french.ldf)                of your document; reported on input line 3.

which can be avoided by adding

\usepackage[T1]{fontenc}

or by using lualatex or xelatex.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.