2

I had the same error as this question:

tlmgr: Remote repository is newer than local (2017 < 2018)

Namely, I was trying to install helvet and had the following error

$ tlmgr install helvet
(running on Debian, switching to user mode!)
tlmgr: Remote repository is newer than local (2017 < 2018)
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
Please see https://tug.org/texlive/upgrade.html for details.

So, I ran the command given as an answer:

sudo tlmgr option repository ftp://tug.org/historic/systems/texlive/2017/tlnet-final

And now I get this:

$ tlmgr install helvet
(running on Debian, switching to user mode!)
TeX Live 2017 is frozen forever and will no
longer be updated.  This happens in preparation for a new release.

If you're interested in helping to pretest the new release (when
pretests are available), please read http://tug.org/texlive/pretest.html.
Otherwise, just wait, and the new release will be ready in due time.
tlmgr: package repository ftp://tug.org/historic/systems/texlive/2017/tlnet-final (verified)
tlmgr install: package helvet not present in repository.
tlmgr: action install returned an error; continuing.
tlmgr: An error has occurred. See above messages. Exiting.

Which, I don't know, also seems maybe worse. So, I'd like to revert my package from the 2017 frozen to whatever it was before.

My question is: What is the default remote and how can I set back to it?

I scouted around the ftp directory:

ftp://tug.org/historic/systems/texlive/

And there wasn't a clear version of 2018 that looked parallel to:

ftp://tug.org/historic/systems/texlive/2017/tlnet-final/

eg, nothing in:

ftp://tug.org/historic/systems/texlive/2018/

resembles tlnet-final to me.

(If you can also point me to how to install helvet, or arial, or URW Nimbus Sans, or anything that will keep my tex from failing to load a sans font, also great. Everything I have attempted so far seems to have messed up my system in various ways rather than effectively install a font.)

  • 1
    You made the same mistake as in the linked question: using the distro's TeX Live. And there's also a simple reason that your URL manipulation failed: TL2018 is not historic yet, i.e. it still receives updates. – TeXnician Nov 6 '18 at 6:39
  • Thanks, I know. But after I have made this mistake, how do I go back to whatever the 2018 correct one was I had in the first place? – Mittenchops Nov 6 '18 at 15:41
  • Have you tried mirrors.ctan.org? – TeXnician Nov 7 '18 at 6:12
  • Is your issue solved? How? – Kurt May 28 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.