2

I'm quite new Latex so excuse my ignorance. I have translator set in my .bib file however when I use \printbibliography no translator is printed. So currently my reference looks like this:

Surname, A. (2018). Article Title. Journal,10(3),92–101

When it should look like this:

Surname, A. (2018). Article Title (B. Translator, Trans.). Journal,10(3),92–101

Does the apa style in Biblatex allow for the translator option?

As an aside I found using the apacite package would output a translator to the bibliography, however I couldn't find a way to output a full reference (such as what would appear in the bibliography) for my list of figures. I tried using \caption[{\fullcite]{Figure text} but I quickly learned apacite doesn't have a \fullcite equivalent. This prompted my switch to biblatex - that and I read the apa style for biblatex is supposed to be the 'correct' way to cite apa in Latex.

Many thanks!

Edit: full example, thanks to samcarter

main.tex

\documentclass[a4paper, twoside, 10pt]{report}
\usepackage[utf8]{inputenc}
\usepackage[british]{babel}
\linespread{1.6}
\setlength{\parindent}{4em}
\usepackage{fullpage}
\usepackage[Sonny]{fncychap}
\usepackage{fancyhdr}
\usepackage{graphicx}
\graphicspath{ {images/} }
\usepackage[backend=biber,style=apa,sorting=ynt,language=british]{biblatex}
\DeclareLanguageMapping{british}{british-apa}
\addbibresource{literature.bib}
\usepackage[font=footnotesize,labelfont=bf]{caption}
\usepackage{parskip}
\usepackage[toc, acronym]{glossaries}

\begin{document}
\chapter{Chapter 1: The Problem}
\section{The Reference}
Here is some writing with a citation \parencite[p.6]{reference1}
\printbibliography\newpage
\end{document}

literature.bib

@article{reference1,
    title={The Works of John Smith},
    author={Smith, J.},
    translator={Peter Holmes},
    journal={Science Journal},
    volume={10},
    number={3},
    pages={92-105},
    year={1999},
    language = {german},
}
  • 2
    Welcome to TeX.SE. It would be helpful if you composed a fully compilable minimal working example with bibliography (MWEB) including \documentclass and the appropriate packages that sets up the problem. While solving problems can be fun, setting them up is not. Then, those trying to help can simply cut and paste your MWE and get started on solving the problem. – user36296 Nov 6 '18 at 22:04
  • Thanks samcarter for the typo corrections! Example added. – awildestack Nov 6 '18 at 23:34
  • 2
    biblatex-apa uses translator information for entrytypes book, inbook, incollection and inproceedings. But not for other entrytypes, as far as I dug. You have there an article entrytype for "The Works of John Smith", are you sure you are using the right entrytype for your actual case? – gusbrs Nov 6 '18 at 23:56
  • Yep, I can confirm it is a journal article which I've had translated. – awildestack Nov 7 '18 at 0:11
  • If you've had it translated, then aren't you referencing the translation (which is unpublished), rather than the original published article? – David Purton Nov 7 '18 at 0:15
4

You can make a new macro to output the translator for an article and then patch the article driver to include it.

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{Surname2018,
  author = {Surname, A.},
  date = {2018},
  title = {Article Title},
  translator = {Translator, B.},
  journaltitle = {Journal},
  volume = {10},
  number = {3},
  pages = {92-101}
}
\end{filecontents}
\usepackage[style=apa]{biblatex}
\addbibresource{\jobname.bib}
\newbibmacro*{article:trans}{%
  \ifnameundef{translator}
    {}
    {\printtext[parens]{%
       \printnames[apanames][-\value{listtotal}]{translator}%
       \setunit{\addcomma\addspace}%
       \printtext{\bibcpstring{translator}}%
       \clearname{translator}}}}
\usepackage{xpatch}
\xpatchbibdriver{article}
  {\usebibmacro{title}}
  {\usebibmacro{title}%
   \setunit{\addspace}\newblock
   \usebibmacro{article:trans}}
  {}
  {}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

enter image description here

  • Absolutely perfect, thanks very much David! – awildestack Nov 7 '18 at 3:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.