0

I am using TexLive full 2017 on Linux Mint 19 Tara machine. I have installed biber 2.9 as well. All works fine when I have backend as bibtex but when change that to biber, this does not create bib file. When I run bibliography on the file, it caused an error message saying that,

Error: One command expansion invalid.
    Parent Command: bibliography
    Primary Command: bibliography

What would be the problem?

Note:

I use Texstudio as my front end and I didnt forget the change the Default bibliography tool as biber in my configuration settings.

Here is the MWEB.

\documentclass{article}
\usepackage[backend = biber,style=authoryear-comp]{biblatex}
\addbibresource{\jobname.bib}
\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@book{key,
  author = {Author, A.},
  year = {2001},
  title = {Title},
  publisher = {Publisher},
}
\end{filecontents}

\begin{document}

\cite{key}

\printbibliography

\end{document}

Here is my log file

  • 2
    According to your .log file you are running biblatex 3.10. The corresponding Biber version would be 2.10 and not 2.9. How did you install Biber? I assume your TeX live was installed via apt-get? Why don't you install Biber that way as well, then the versions should match. – moewe Nov 7 '18 at 11:17
  • @moewe apt-get installs biber 2.9-1 only... – David Nov 7 '18 at 11:43
  • And how did you install biblatex? Surely the versions of biblatex and Biber installed via apt-get should match... – moewe Nov 7 '18 at 11:45
  • I have installed texlive-full via synaptic package manager..and run apt-get install texlive-full after your comment. It says that the current version is upto date..Should I doapt-get install biblatex? – David Nov 7 '18 at 11:51
3

Indeed it seems that the repositories for Bionic Beaver (Ubuntu 18.04) contain texlive-base in version 2017.20180305-1 (https://launchpad.net/ubuntu/bionic/+source/texlive-base) with biblatex 3.10.

But at the same time the Biber version in the repositories is 2.9 (https://launchpad.net/ubuntu/bionic/+source/biber).

Those two versions are incompatible per the biblatex/Biber compatibility matrix that can be found in the biblatex documentation or the Biber manual.

There already is a bug open for that issue at https://bugs.launchpad.net/ubuntu/+source/biber/+bug/1770516 and I suggest you add a comment that this is indeed a serious problem that needs to be resolved.

For the time being I only see two work-arounds

  1. Get Biber 2.10 from https://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/2.10/binaries/ and install it manually. Usually manual installs are strongly discouraged, but desperate times call for desperate measures.

  2. Completely remove the TeX live from the Ubuntu repositories and install a vanilla TeX live from TUG instead. See How to install "vanilla" TeXLive on Debian or Ubuntu?. The advantage of vanilla TeX live is that you can use tlmgr to update your packages.

  • +1 for "desperate times call for desperate measures". :-) – Mico Nov 7 '18 at 13:25
  • I did installed the vannila texlive using the link provided. Ofcourse it look lot of time. But when I run sudo tlmgr update --self It gave me (running on Debian, switching to user mode!) tlmgr: Remote repository is newer than local (2017 < 2018) Cross release updates are only supported with update-tlmgr-latest(.sh/.exe) --update Please see https://tug.org/texlive/upgrade.html for details. – David Nov 8 '18 at 2:46
  • @David Did you make sure to remove the other TeX live installation completely? There were questions with similar symptoms here and all were caused by remnants of the old system hanging around. – moewe Nov 8 '18 at 5:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.