3

I have a follow-up question to biblatex: displaying all authors of multi-author works in the bibliography.

For that question, in LyX, we cannot simply write \usepackage[maxbibnames=99]{biblatex} in the preamble to address the problem. The reason is stated in https://wiki.lyx.org/BibTeX/Biblatex, Using Biblatex with LyX 2.3.0 and newer, step 5.

In the preamble

  • remove \usepackage[…]{biblatex}
  • remove \addbibresource{…}
  • embrace biblatex-related commands with

    \AtBeginDocument{%
      <your commands>
    }
    

Thus, we cannot use \usepackage[maxbibnames=99]{biblatex} in current version of LyX. Then how can we address this problem? I have worked on this for a whole day... Who would propose a solution?

2

Assuming you have your document set up for biblatex already you can pass options to the package as follows.

  • Go to Document > Settings.
  • Choose Bibliography in the left pane.
  • Under Citation Style, pass your options to biblatex by putting them into the Options field.

The screenshot shows the "LyX: Document Settings" accessed via "Document > Settings" in the "Bibliography" pane. The "Options" field is highlighted and contains the text <code>maxbibnames=999</code>. In the background a LyX document with two example citations and a bibliography is visible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.