I made an update of my 2 years old miktex installation yesterday, and since then, when I try compiling (using latex -> dvips -> ps2pdf, or directly in pdf with pdflatex) the file seems to be compiled 4 times, and I get this message :

Stopping after running "LaTeX" 4 times in a row.
LaTeX: problems after {1} page

with this log :

Running `LaTeX' on `test1' with ``pdflatex -enable-write18  -file-line-error   -interaction=nonstopmode "\input" "test1.tex"''
This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6840 64-bit)
entering extended mode
LaTeX2e <2018-04-01> patch level 5
(test1.tex ("C:\Program Files\MiKTeX 2.9\tex\latex\base\article.cls"
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
("C:\Program Files\MiKTeX 2.9\tex\latex\base\size10.clo")) (test1.aux) 
[1{C:/Users/xxxxx/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}] 
(test1.aux) )<C:/Program Files/MiKTeX 
2.9/fonts/type1/public/amsfonts/cm/cmr10.pfb>
Output written on test1.pdf (1 page, 11654 bytes).
Transcript written on test1.log.

TeX Output finished at Thu Nov  8 14:59:23

Source file is a simple :

\documentclass{article}

\begin{document}

Test ! 

\end{document}

Also, my pdf viewer doesn't open to show the result (but it is correct).

I use emacs + auctex to edit source file.

closed as off-topic by siracusa, marmot, Troy, Stefan Pinnow, TeXnician Nov 10 at 7:54

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • the log looks ok. Probably auctex or whatever tool you are using to do more than one compilation is misinterpreting the log. – Ulrike Fischer Nov 8 at 14:10
  • Thanks. That's weird because it worked before the update... The log format has not changed with recent versions of pdfTeX ? (if there was any...) I'll update auctex, but I'll have to configure emacs, I hate that :) – T. Tournesol Nov 8 at 14:17
  • 1
    Sorry I can't tell you. I'm not using emacs and auctex and I'm even not sure if the message is from them or from some other automation tool. – Ulrike Fischer Nov 8 at 14:26
  • It's probably related to the way your AUCTeX version parses dates in the .log files. Please update your AUCTeX version or see the manual patch mentioned in this thread – siracusa Nov 8 at 15:23
  • 4
    I'm voting to close this question as off-topic because it was solved in the comments – siracusa Nov 10 at 1:07