I have a simple test document, that stops working if


is included in the preamble. I use TeXnicCenter in conjunction with pdflatex. I wanted to generate a tikz file with gnuplot 4.4.4 (with the gnuplot-tikz.lua file from 4.4.3, because the 4.4.4 version is broken) and then compile it with latex, but as it is now including the necessary package mentioned above suppresses all output. I have copied the file gnuplot-lua-tikz.sty to the same directory as the tex file that I am trying to compile (code shown below):

\section{Section 1}

The above example results in the following on compiling:

LaTeX-Result: 0 Error(s), 0 Warnings(s), 0 Bad Box(es), 0 Page(s)

If I remove the line \usepackage{gnuplot-lua-tikz}, everything works. How can there be zero errors and also no page output? What do I need to do to get output?


PS: I also want to include a tikz-picture that gnuplot generated, but I have omitted that code (quite long) since I get the same result on compiling -- zero errors and zero pages -- whether I include the picture or not.

PS2: I don't really know what lua is or how it works, so if the answer has to do with lua, I would be grateful if "lua-related stuff" is explained.

  • Hi hjb981, I've removed the thanks. It's just the style here, and thanks is best expressed as upvoting those answers that help you.
    – qubyte
    Feb 27, 2012 at 12:52
  • It works fine for me. You might try looking at the log file (located in the same directory as your Latex document), and see if it has any complaints. Feb 27, 2012 at 17:01
  • I had a look at the log file, and it looked similar to other log files, except that the last parts were missing (i.e., where the MPS to PDF converter gets loaded). I am no expert on this, and I may have missed something.
    – hjb981
    Feb 27, 2012 at 17:53

1 Answer 1


Reinstalling MiKTeX solved the issue.

It appears that some part of my MiKTeX 2.8 / TeXnicCenter installation had become corrupt. Yesterday, even old files that I new should compile without problems started to give the 0 error(s) and 0 page(s) result. The MiKTeX maintenance tools did now work as they should either when I tried to "update FNDB" and "reset formats" (I got errors). I ended up reinstalling MiKTeX (in the process I also upgraded from 2.8 to 2.9), and now it works again, including the gnuplot-lua-tikz package.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .