1

At the moment I'm working on my thesis using latex. Now I ended up with an interesting problem.

I use the \footcite command in my text to get a footnote with biblatex. I also had a table on the same side in an floating environment. Even though there is enough space on the page, the table ends up below the footnotes. It is fine if the table is floating around (I mean that is, what floating environments are for) but I guess they need some barriers. I have a barrier with the placeins package, but it only assures that the floats don't leave the chapter. I checked some other threads but they discuss footnotes in tables or floating of tables in general.

Here is some minimal code to check what I did, I hope you can help me.

\documentclass[english, 12pt]{scrartcl}
\KOMAoption{
titlepage=firstiscover,
sectionentrydots=true,
captions=tableheading,
bibliography=totoc
}
\usepackage{blindtext}
\usepackage[section]{placeins}
\usepackage{setspace}
\usepackage[backend=biber,style=nature,uniquename=init]{biblatex}
\addbibresource{test.bib}

\begin{document}
\pagenumbering{arabic}
\onehalfspacing

    \section{chapter 1}
This Text includes a Footnote\footcite{eins}, a table and some blindtext to fill the Page. \blindtext

\begin{table}
\captionbelow{This is an example}
\begin{tabular}{llll}
Dies & ist & ein & Beispiel.\\\hline
Bitte & lassen & Sie & den \\
Inhalt & dieser & Tabelle & unbeachtet.
\end{tabular}
\end{table}

\printbibliography

\end{document}
  • you can put \clearpage or \FloatBarrier before \printbibliography – David Carlisle Nov 14 '18 at 13:40
  • 2
    Welcome to Tex.SE. Did you try \begin{table}[ht!] instead of \begin{table}? – nidhin Nov 14 '18 at 13:45
  • The Problem is not with \printbibliography, the problem is on page 1. I have the text, then there is the footnote and then there is the table. But the footnote should be on the bottom end as it is always, not somewhere above a table. I don't want to force the floating enviroment by using \begin{table}[ht!] – Inselino Nov 14 '18 at 14:04
  • 2
    You are missing the closing } from \KOMAoption{ – user36296 Nov 14 '18 at 14:06
  • 2
    To force footnotes to be placed at the bottom of the page, try loading the footmisc package with the option bottom. – Mico Nov 14 '18 at 14:23
1

As Mirco said in a comment, an easy way to force footnotes is the package \footmisc.

The code you need to include is \usepackage[bottom]{footmisc}

It is not perfect because I don't like to include a different package each time I have problem but it is a quick fix for a problem and it does not seem to interfear with the KOMA Script or biblatex so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.