2

I need to increase the spacing between lines for my thesis.

It seems like "setspace" is what I have to use (\usepackage{setspace}) but i get...

The required file tex\latex\setspace\setspace.sty is missing...
Package will be installed from > Change > Installation source.

That's fine, problems start here:

  • If I choose "should be installed from Internet", I need to specify connection settings, only option is "use a proxy server", but it will only tell me "connect failed in tcp_connect()".
  • If I choose "should be installed from a directory", I fail to find the appropriate directory and only get the error "Not a local repository."

I tried to download from https://www.ctan.org/pkg/setspace but am unable to find where to copy the files.

I tried MiKTeX-Package-Manager, found setspace, clicked "+", but get a MiKTeX-ProblemReport saying "No Data" and "get host by name failed in tcp_connect()"

As an alternative I have tried \baselineskip=1.5\baselineskip, but it won't increase spacing between lines in my bibliography (embedded with \bibliography{bib}).

Can you give me directions? Thank you!

Edit:

I used \linespread{1.5} and it seems to work.

It would still be interesting why I can't install any packages. My problem seems to be the same as described in MiKTeX: connect failed in tcp_connect. But I have no clue about proxies so I can't proceed.

closed as off-topic by Mensch, Circumscribe, Stefan Pinnow, user36296, Romain Picot Dec 19 '18 at 10:10

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    To setup a local repository you need the files from ctan.org/tex-archive/systems/win32/miktex/tm/packages. You need at least the files starting with miktex-zzdb, and the packages you want to install. Put them all in some empty folder outside miktex. – Ulrike Fischer Nov 14 '18 at 15:44
  • 4
    I'm voting to close this question as off-topic because the server was temporaly not available. Now it is online ... – Mensch Dec 19 '18 at 9:09
0

Same problem here. Looks like the package repository is temporarily offline. Don't know when it will work again.

Message on Miktex.org

  • As of this morning (UTC) this warning message is gone and at least for me update worked brilliantly a few minutes ago. – moewe Nov 16 '18 at 9:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.