3

enter image description here

I can't figure out why my bibliography renders weird quotation marks. Sometimes they do not close, sometimes they wrap around a part of the author's name. My document looks like this:

\documentclass[12pt]{amsart}
\usepackage[spanish]{babel}   
\usepackage{csquotes}

\title{Trabajo en base de datos 2: Reseña\\
\large Introducción a la modelación matemática de la naturaleza
}
\author{Fundación Universitaria Konrad Lorenz\\Curso: Cálculo Diferencial\\Estudiante: Jonatan Ahumada\\ Cód.506181029}

\begin{document}
\maketitle
\cite{chejne2016aproximacion}
\cite{knuth2005art}
\bibliographystyle{apacite}
\bibliography{referencias}      
\end{document} 

And my .bib file looks like this:

@article{chejne2016aproximacion,
  title={Una aproximaci{\'o}n a la construcci{\'o}n de modelos matem{\'a}ticos para la descripci{\'o}n de la naturaleza},
  author={Chejne, Farid},
  journal={Revista de la Academia Colombiana de Ciencias Exactas, F{\'\i}sicas y Naturales},
  volume={40},
  number={155},
  pages={353--365},
  year={2016}
}
@misc{knuth2005art,
  title={The Art of Computer Programming, Volume 4, Fascicle 2: Generating All Tuples and Permutations},
  author={Knuth, Donald E},
  year={2005},
  publisher={Addison-Wesley Professional Boston, MA}
}

Furthermore, I made my .bib file pasting the code from GoogleScholar, so I know the .bib is fine. It just seems as if \apacite doesn't know where to open quotations or where to close.

I'm very new to LaTex, any help would be much appreciated.

3
  • 1
    Welcome to TeX.se. It will be very hard to help you with just an image. Please edit your question to show a small compilable document that can reproduce the problem, along with the actual .bib entry that you are using. The document should begin with \documentclass{...} and end with \end{document} and load only the apacite package and any font or input encoding packages you are loading, nothing else. – Alan Munn Nov 15 '18 at 4:07
  • @AlanMunn thanks, I followed your instructions. Not sure if babel package was a "font or input encoding" package so I left it. I also cut out all the text, to make it easier on the eyes. I hope it compiles fine. – jonathan ahumada Nov 15 '18 at 4:30
  • Thanks! This is fine, and it was good to include babel and csquotes. But I'm surprised you get any output at all; the code as posted produces errors because the apacite package isn't loaded. – Alan Munn Nov 15 '18 at 4:46
2

The apacite bibliography style needs to be used in conjunction with the apacite package. So you need to modify your document like this. I've loaded the apacite package with the [natbibapa] option, which allows you to use natbib citation commands. If you want to use the original apacite commands you can leave that option off. See the following question for some details on the difference:

\documentclass[12pt]{amsart}
\usepackage[spanish]{babel}   
\usepackage{csquotes}
\usepackage{apacite}
\title{Trabajo en base de datos 2: Reseña\\
\large Introducción a la modelación matemática de la naturaleza
}
\author{Fundación Universitaria Konrad Lorenz\\Curso: Cálculo Diferencial\\Estudiante: Jonatan Ahumada\\ Cód.506181029}

\begin{document}
\maketitle
\cite{chejne2016aproximacion}
\cite{knuth2005art}
\bibliographystyle{apacite}
\bibliography{referencias}      
\end{document}

Some comments on your .bib entries. Google Scholar doesn't always provide the best .bib entries; they are sometimes full of errors. In the example you show, for instance, I would preferably use:

@book{knuth2005art,
  title={The Art of Computer Programming},
  author={Knuth, Donald E},
  year={2005},
  volume={4 Fascicle 2: Generating All Tuples and Permutations},
  publisher={Addison-Wesley Professional},
  address={Boston, MA}
}

enter image description here

1
  • Hi @AlanMunn. Thank you again. This will be hard to explain. First, I did have apacite loaded but I erased it while I was posting my question. I'm deeply sorry for wasting your time. However, when I ran your code on a new document it compiled just fine. This baffles me, because im pretty sure the other was also alright. I even changed the bib file on the other to no avail. Well, I guess that's life. Thank you. – jonathan ahumada Nov 15 '18 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.