2

I am trying to compile my manuscript. I am using a large bibtex database that contains conference papers, in addition to my custom bib file.Also I am using the CCS template, as follows:

\bibliographystyle{ACM-Reference-Format}
\bibliography{mybibliography,abbrev3,crypto}

But when I compile my tex, I am getting the following errors, and the reference list does not show up:

This is BibTeX, Version 0.99d (TeX Live 2017/Debian)
The top-level auxiliary file: main.aux
The style file: ACM-Reference-Format.bst
A level-1 auxiliary file: appendix.aux
Database file #1: mybibliography.bib
Database file #2: abbrev3.bib
Database file #3: crypto.bib
Sorry---you've exceeded BibTeX's hash size 100000
Aborted at line 291526 of file crypto.bib
(That was a fatal error)

Process exited with error(s)

However, if I break the bib files into 3 separate lines, it compiles (with some warnings) but I am getting my references displayed 3 times...

\bibliography{mybibliography}
\bibliography{abbrev3}
\bibliography{crypto}

Is there any solution for that? I have tried looking on how to increase the Bibtex hash size but couldn't find anything...

  • 1
    Use bibtex8 (instead of bibtex) with the option --wolfgang or set --mstring to some (very) high value. – DG' Nov 15 '18 at 19:52
  • Tried both, --wolfgang didn't work as well with bibtex8, I also tried --mstring 1000000 and I got error TeX capacity exceeded, sorry [save size=80000]. {ISC:KanSulHaq07} – bomberb17 Nov 15 '18 at 21:57
  • You can set save_size to a higher value by editing texmf.cnf (which you can find with kpsewhich texmf.cnf) → tex.stackexchange.com/questions/134597/… – DG' Nov 15 '18 at 22:30
  • Nope.. Added save_size = 100000 to /etc/texmf/web2c/texmf.cnf but still same error. – bomberb17 Nov 15 '18 at 23:06
  • Well, then you have to slim down the bibliography: cryptobib.di.ens.fr/custom – DG' Nov 16 '18 at 7:03
1

TL;DR: Don't use this humongous database, instead copy the relevant entries to a new and slimmer .bib-file


Since crypto.bib is rather huge (21M), you have to use bibtex8 and set --mstrings to a rather high value. I tried bibtex8 --mstrings 700000 and it kind of worked, i.e. bibtex8 still threw lots of warnings and errors.

I compiled a small test document with lualatex:

\documentclass{article}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{natbib}
\usepackage{hyperref}

\begin{document}

\nocite{*}
\bibliographystyle{ACM-Reference-Format}
\bibliography{abbrev3,crypto}

\end{document}

Which produced a neat PDF of 4534 pages:

enter image description here

  • Unfortunately, while bibtex8 seems to work with warnings as you said, when I run pdflatex after I'm getting lots of Underfull \vbox (badness 10000) has occurred while \output is active errors and finally ! Undefined control sequence.. My tex works fine otherwise. I also tried to manually download the database from their website as you suggested but their script seems to be broken.. – bomberb17 Nov 17 '18 at 2:45
  • 1
    @Panos you have to ignore the error. The database too big and buggy to use. You'd be better off, copying the relevant entries to an new .bib-file – DG' Nov 17 '18 at 7:17
  • 1
    @Panos - If you get lots of Underfull \vbox warnings (not errors), try issuing the instruction \sloppy before \bibliography. – Mico Nov 17 '18 at 7:51
  • 1
    @Panos The Undefined control sequence-errors are caused by math in titles of papers (like: "The art gallery problem is $\exists\mathbb{R}$-complete"). You need to load amsmath and amsfonts to get rid of the errors. – DG' Nov 17 '18 at 9:36
  • 1
    Ok I eventually found out that there were a couple of entries in the database that had some weird stuff in brackets and they were responsible for the undefined control sequence errors. Problem solved. Thanks! – bomberb17 Nov 18 '18 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.