2

I recently installed texlive and texstudio (both last versions) but texstudio doesn't work when I changed the compiler to xelatex. I get the error :

Error: Command crashed: xelatex -synctex=1 -interaction=nonstopmode "texstudio_eB3052".tex

I also installed texlive-xetex package, but still didn't work. Can anyone help me? thanks in advance.

P.s: I have ubuntu 16.04.

closed as unclear what you're asking by Troy, Phelype Oleinik, Kurt, Stefan Pinnow, Henri Menke Nov 27 '18 at 3:17

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • what happens if you type xelatex sample2e on the commandline? check it works there before getting it working via an editor – David Carlisle Nov 16 '18 at 7:43
  • yes it works in the terminal. – Bob 22 Nov 16 '18 at 7:48
  • OK I t's presumably a path issue the but I can't help as texstudio isn't emacs:) – David Carlisle Nov 16 '18 at 7:49
  • Is your file really called texstudio_eB3052.tex? And if yes what happens if you try to compile it on the terminal with the quotes mentioned in your error message? – Ulrike Fischer Nov 16 '18 at 7:57
  • that was an untitled file. when i type the command: xelatex sample.tex in terminal, I get: This is XeTeX, Version 3.14159265-2.6-0.99999 (TeX Live 2019/dev/Debian) (preloaded format=xelatex) restricted \write18 enabled. entering extended mode (./sample.tex LaTeX2e <2018-04-01> patch level 4 Babel <3.20> and hyphenation patterns for 3 language(s) loaded. (/usr/share/texlive/texmf-dist/tex/latex/base/article.cls Document Class: article 2014/09/29 v1.4h Standard LaTeX document class (/usr/share/texlive/texmf-dist/tex/latex/base/size10.cloSegmentation fault (core dumped) – Bob 22 Nov 16 '18 at 8:05