4

During the last days I am really stressed because I face a problem with my References that I never had before. With the following, I try to generate my bibliography but I either get the error "\providecommand\NAT@force@numbers{}\NAT@force@numbers", or I get my document with question marks instead of bibliography names/dates.

Any ideas how to spot the issue which causes me this and fix it?

here are my two .bib files

I do not want to use natbib with numbers but with names and I do not understand the reason why I have this issue. I read similar issues but I can not spot any missing dates on my files which previously were fine and that is why I am confused.

P.S. I show you all the packages that I use in case something else causes the problem.

\RequirePackage{filecontents}
\documentclass[12pt,a4paper]{article}
 \listfiles
\usepackage{amsthm}
\usepackage{titling}
\usepackage[utf8]{inputenc}
\usepackage{tcolorbox}
\usepackage{graphicx}
\usepackage{lipsum}
\usepackage{mwe}
\usepackage{subfig}
\usepackage{float}
%\usepackage{cite}
\usepackage[authoryear,round]{natbib}
%\usepackage[numbers]{natbib}
\usepackage{enumitem}
\usepackage{amsmath}
\usepackage{mathtools}
\usepackage{multicol}
\usepackage{stfloats}
\usepackage{authblk}
\usepackage{afterpage}
\usepackage[T1]{fontenc}
%\usepackage[hidelinks]{hyperref}
\usepackage[colorlinks = true,
linkcolor = blue,
urlcolor  = blue,
citecolor = blue,
anchorcolor = blue]{hyperref}
\usepackage{amsfonts}
\usepackage{booktabs}
\usepackage{fancyhdr}
\usepackage{array}
\usepackage{pdflscape}
\usepackage{array,ragged2e,booktabs}
\usepackage{tikz}
\usepackage{longtable}
\usepackage{capt-of}
\usepackage{tabularx}
\usepackage{textcomp}
\usepackage{makecell}
\usepackage[british]{babel}
\usepackage[euler]{textgreek}
\usepackage{makecell}
\usepackage{xcolor,colortbl}

%\usepackage{dirtytalk}
%\usepackage[none]{hyphenat}
%\hyphenation{sy-ner-gi-stic}
%\usetikzlibrary{shapes.geometric, arrows}
\pagestyle{fancy}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%\fancyhf{}
\lhead{}

\makeatletter
\def\thanks#1{\protected@xdef\@thanks{\@thanks
        \protect\footnotetext{#1}}}
\makeatother
\renewcommand\tabularxcolumn[1]{m{#1}}
\definecolor{LightCyan}{rgb}{0.88,1,1}
\definecolor{Burntsienna}{rgb}{0.91,0.45,0.32}

\date{}

\newcolumntype{C}{>{$\displaystyle}c<{$}}
\bibliographystyle{apalike}
\setlist[enumerate]{label*=\arabic*.}
\begin{document}
        \title{\vspace{-3.0cm}\rule{\textwidth}{1pt}\\title here \\\vspace{1.0cm}\rule{\textwidth}{1pt}\\{\Large Probation Report}}
    \author{author here\thanks{department here}}

    \maketitle
    \newpage
    \tableofcontents
    \newpage
    \renewcommand{\thesection}{\arabic{section}}


    \section{bla bla}
    bla bla bla bla  \citep{holling_resilience_1973,gunderson_ecological_2000} bla bla bla  \citep{gunderson_ecological_2000}. bla bla bla bla bla bla  \citep{achard_areas_2006, alkama_biophysical_2016, appenzeller_new_2015, bergeron_ecosystem_2017, berner_plant_2013,brown_once_2012, chapin_global_2004, forkel_trend_2013, forkel_codominant_2015, furyaev_effects_2001, lucht_terrestrial_2006, rydgren_disturbance_2004, jasinski_creation_2005, soja_climate-induced_2007, scheffer_thresholds_2012, williams_who_2011, young_climatic_2017, vygodskaya_ecosystems_2007, tanja_air_2003}. 




\newpage
\section{References}
%\nocite{*}
\bibliography{fone,ftwo}
\newpage
\section{Supplementary material}

\end{document}
2
  • 2
    Why are you using two bibliographystyle commands? (plainnat and apalike)? Nov 16, 2018 at 9:20
  • @UlrikeFischer apologies, I do not, it is just a mistake here, I will edit my question. Thanks.
    – geo_dd
    Nov 16, 2018 at 9:32

1 Answer 1

3

In my experience, this error is caused by bibliographic references that are missing a year. Loading the bib files into JabRef and sorting by year should help you to identify the problematic entry.

2
  • I know that missing dates and authors may cause this problem. I will try to load them in zotero and check them.
    – geo_dd
    Nov 16, 2018 at 9:48
  • Thank you very much. I was looking for no date references in TexStudio and missed two of them. It is better to do it through zotero directly. Thank you!
    – geo_dd
    Nov 16, 2018 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.